Firmware update R211 released for SanDisk Extreme SSD

In case it helps anyone, I was able to update after retrying with the USB stick. Possible my CD image was corrupted but odd that it worked otherwise.

You do not need to update your firmware as you do not have the affected NVidia MCP79 chipset. I have a 17" MBP 6,1 and have the the Intel 5 Chipset; see picture.

MBP 17 6,1 with Intel 5 SATA Controller

I hope this helps. I have no problems with my SSD

You do not need to update your firmware as you do not have the affected NVidia MCP79 chipset. I have a 17" MBP 6,1 and have the the Intel 5 Chipset; see picture.

MBP 17 6,1 with Intel 5 SATA Controller

I hope this helps. I have no problems with my SSD

Hi,

Im using a Macbook Unibody Late 2009 and recently this year I upgraded from an HDD to a Sandisk Extreme SSD240G. The speeds are extremely fast with the standard firmware on the drive.

Next, I decided to do a fimware update to get 3gb negociated link speeds using the R211m firmware. Originally, with the nVidia chipset before the new firmware, the link speed was only 1.5gb yet it was still fast and showed no lagg so I wanted to see if it would get faster with 3gb link speeds.

Since the update, BlackMagic benchmark apps shows that  my read and write speeds have doubled. 

However from use and my owm comparison, I feel like there is a little lagg when I open my applicatioons. The updated SSD actually seems slower than what it was with the old firmware.

Even though the negociated link speeds went from 1.5gb to 3gb, there is a bit of lag and delay with the new update. 

Is there a reason for this? Will there be new updates? Thanks   

if your benchmark speed doubled there is no reason you should feel a lag opening apps. 

Rule of thumb, don’t ever try to update or fix something which is not broken, sometimes we would very much regret things. I learned this the hard ware upgrading an SSD with no issues.

Nice and easy update, no problems here! Just a shame I need to burn a disc. OSX client please!

I want to make sure I understand this before doing something I will regret. It’s my understanding that the R211 firmware update is for non-Mac machines and the R2111m is for Macs, right?

I have my Extreme 240GB SSD installed in a machine I built myself. The motherboard is an MSI X58 Pro-E. The South Bridge is an Intel ICH10R chipset. It triple boots between Windows 8 (Release Preview), Windows 7, and Ubuntu Linux.

r211 is for everything that does not use older nividia SATA chipsets. you will need to use r211 firmware update. 

I have installed this update, but I still am having a problem getting a DPC Watchdog violation. according to some other forums, it is because of the firmware of the ssd. I have windows 8 x64 and I would really like to use it. can anyone help me out?

Just bought the 120GB extreme and the 240 Extreme - the 120 had FM R112, and the 240 had R201

I put the 120GB in my Mac Mini 2011 and the 240 in my MBP 13" 2011. 

For the MBP - was easy to upgrade: downloaded the ISO, disk utility to burn onto a disk and followed the instructions - and the speed difference is REALLy noticable. Boot time 12 seconds, 40 seconds to boot and load all my default progs: chrome, firefox, skype, Parallels (Windows XP) and a bunch of other stuff…

Now for the Mac Mini it was painful and really SanDisk should start supporting Mac much better - as the 2011 model has no CD drive. 

So, I took out the Mini 120GB disk, and had to put it into the MBP, burned the iso file (somehow the FM installer only works if the iso file was burned with the Mini SSD in the MBP. Tried burning the iso disk before I put the Mini disk in and it didnt work. 

OK - so apart from the hassle of taking apart the Mini and swapping disks - the process was atually very smooth. 

And again the difference is really noticable: boot time around 15 seconds again, a bit longer to open all the default programs (less than in my MBP as the mini is my media server running Plex). 

Anyways - hope that helps people - process is actually fine (apart from disk swapping the mini into MBP etc) - and the difference is awesome. 

Also, both are running 10.8.2 - and I installed TRIM Enabler - seems to work, System Information shows that TRIM is working, so hopefully that is actually the case. 

Next on the list: the iMac 27" - that’s gonna be a real job!!!

I am trying to get my bootable usb drive (or any other drive for that matter - tried others) to boot my laptop and install firmware r211 from r201.  Boot screen just stops after a few lines of code with no further action.  I have to turn off the computer and reselect boot from hardisk (SSD Extreme 240gb).  Disk still reads firmware version r201.

Used the latest version TooKit downloaded from SanDisk to configure my USB et al.

I have an ACER Aspire 1830T, Intel dual core I7, with 8gb ram.

Thanks for any advice on what I may be doing wrong.

try creating the CD instead of the USB drive and use it to boot and upgrade the firmware. 

I updated from an external CDROM eventually. I have 2 SSDs in the internal bays and am on a 2012/3 MacBook Pro (non retina).

Firstly, I tried a bootable USB key made using unetbootin (in Xubuntu). This would be detected by efi on boot but just went to black screen on selecting it as boot device.

I then tried making a CD from the same iso image and this had the same issue, refind would show it in the menu but it would then black screen after selecting it.

I then unplugged my exernal USB docking station (KB/Mouse/Network/Audio) from one of the USB ports and still got a black screen from the USB key, even after I had re-downloaded, reformatted and re-created the USB image using unetbootin.

In desperation, I tried the external CD again and it booted, detected the SSD’s and allowed me to upgrade the 240G Extreme.

At no point were the CD or USB key plugged into the docking station, they were both inserted direct into the laptop. It seems that any other USB peripherals also plugged in at the same time as the boot device may well be the issue here.

Hope this helps anyone else struggling.

Hello, I am a bit confused does this update reset my drive to SATA 3.0. I bought this extreme as i need only super fast stuff fro my Alienware m 18x R2.

Waiting for response

this is the regular FW. it is SATA 3. if you are using a MB with an Nvidia MCP79 SATA chipset use the R211m FW download linked at the top of the board. r211m locks the SSD at SATA 2. If you used the SSD on a board with the MCP79 chipset and now want to reverse the SATA 2 lock use the r211m reversal FW linked in the r211m thread. 

@Tabashir: thanks for your helpful tips.

I have *finally* - after about a year of trying - managed to update the firmware.  I could not get the CD to work even as you described.  But by removing all the other USB devices, I was successfully able to get the USB stick to work.  Hurrah!

But what a complete pain this has been.  Sandisk = this is an object lesson as to how to frustrate and annoy your customers.  The testing on your Sandisk Toolkit is inadequate (did you actually try burning a CD using it???  Where is the download stored?)  And the instructions and help for Mac users is inadequate.

It does not make me feel inclined to buy another Sandisk SSD to be honest.

I wonder if it will be released new firmware updates for our SSD ?

That depends mainly on SandForce. They are currently at 5.04, I did not see any plan for future updates.

Really I got good info guys, thank you guys…