firmware update problem

hi, I just bought this media and tried to update the firmware as requested. 

i downloaded the file form this website, and transferred it from my computer to the device, but nothing happens. what else can i do? 

make sure the FW file is on the root of the media drive. next in the app settings log into the admin settings. Where it says upgrade media drive it will ahve a version number listed beside it. if your says 2.93 you ahve the latest. if it does not say 2.93 tapping upgrade media drive should trigger the FW update. 

It’s says firmware upgrade 2.9 only and nothing happens when i choose it. 

is the FW file on the root of the media drive?

Yes it is. I have followed the instructions as written.

probably need to contact sandisk support

I have the same issue. I have the 2.93 firmware file in the root directory of the drive, but the file is not recognized, and the application keeps prompting me to re-download the firmware from 

An additional side effect, is when I select the play music function of the app, in the android application, the application immediatley terminates. 

If there is not an swer on this in the next couple days, I am returning the drive to Amazon. 

I have the same issue. I have not upgraded it for  while now and my firmware version is 2.03. This version is not recognised by the app and nothing happens except the msg saying to download the latest firmware.

Please help!

Same here.    I bought this for my wife for Christmas after being told in the Apple store that it’s the best thing since sliced bread.

Loads of problems with photo files which all seem to acquire todays date and time after being copied with the odd one having random dates from earlier in the year where the picture was definitely taken today.

There are other reports of this bug in the forum (going back to August) so I had hoped this would be fixed by a firmware upgrade but as in the  comments above nothing happens despite following the instructions to the letter.

I’m a bit peeved to put it mildly :frowning:

Same exact problem here. Tried hard resetting the device, reinstalling the app, everything. Nothing seems to solve. Mine doesn’t lock up when I play music (through the Android app) so I guess I should count my blessings. But this is no good. I could live with it if the nag screens urging me to upgrade would go away.

Just an update: An email to Sandisk support got me advice to reformat the drive and try again. I did so, and had the same result. So I called them and after a morning of back and forth, they could not solve the problem. They offered to replace the drive if I send it to them (their cost; my wait). They did not explain why the firmware upgrade won’t take, but were keen to get the (barely readable) serial number and hinted that it may be a compatibility problem with the driver on some units, if that makes any sense. So I guess I’ll be sending mine in for replacement. I would just use it as is (it seems to work fine in every other way), but am concerned that if it won’t take this update, it won’t take future ones, either. Good luck!

Hi everyone, I had the same issues that everyone has been describing here but after much stuffing around, I have a solution.

  1.   Connect to the drive by WiFi through the app > make sure internet pass-through is enabled > disconnect

  2.   Connect by USB to computer.

  3.   Download the firmware upgrade file and copy to the root of the media drive

  4.   Eject the drive from computer.

  5.   Reconnect COMPUTER to media drive by WiFi.

  6.   Access web-app through a browser.

  7.   Go to Settings

  8.   Log into Admin area

  9.   Click on Upgrade Media Drive

  10. In the modal popup window click on Upgrade.

The Media drive will now upgrade firmware and reboot.

In the Android and iOS Media Drive app you will still get a notice saying a firmware upgrade is available however the web-app will now confirm that the latest firmware has been installed.

A bit of stuffing around but a result at least.  Certainly quicker than returning your drives to SanDisk!!

Hope you find this works for you too.