Failed file transfer on 256GB SanDisk Ultra microSDXC UHS-I


I have a Surface Tablet running Windows 10 Pro.  I bought a 256GB SanDisk Ultra microSDXC UHS-I card to store files on.  When I try and transfer my files, only about the first 5 folders transfer with all the sub-folders and files.  The remainder of the folders transfer over, but they appear empty when you open them.  The size of the used space on the SD card matches the size of the files on the HD, so it would seem like all the files would be there, but I can’t see them.  I’ve tried making changes in View to show hiden folders, but no change.  I’ve also run attrib -h -r -s /s /d k:*.*  replacing k with the drive letter of my memory card; also no change.  I’ve tried doing the transfer on the Surface from an external hard drive, and I’ve tried doing the transfer on my old computer direct to the SD card; again, same results either way.  I’ve also tried both a quick format of teh SD card and the agonizingly slow full format, in exFAT; no difference either way.  Everything I try gets the same results.

Any ideas?  Thanks!

Try running H2testw on it to make sure it’s not counterfeit or otherwise wonky.

Exactly the same happens to me.

Using the adapter provided.

But it seems Sandisk themselves do not monitor this forum.

I’m currently running h2testw on the card.

Not looking good saying 20.6gb corrupted…

I suspect its a fake - hrtest said the vast majority of the card was duff - last time I buy a card from ebay or amazon.

Stick to reputable shops from now on.

Asked for a refund from the ebay seller.


Amazon is usually pretty safe. eBay? Hit or miss. Newegg is also reliable & has very good prices.

Refund given no quibbles…