Fail to backup using Dual USB Drive 16GB

I hope someone can guide me on this.

Just bought Sandisk Dual USB Drive 16GB to be use to store photos from my Moto G (Checked, phone is compatible), when I tried to backup my photos its always fail for no reason and get message “error backup”. Tried the USB to backup photo from computer and it work just fine. 

Anything I should do to resolve the problem?


:smiley:   Hi Andrias,

_ Dear member of SanDisk Community, welcome. _

Check Moto G, see in options, settings, etc.

Luck, and then you tell us, what happened, please.

Regards, Alfred.                                                             (Google translated)

Thanks Cacho (Alfred),

I finaly figure it out how to transfer the photos to the USB. Its working now. So its not by choosing “backup” but by going to the “internal memory” or where ever you put the photos then select the file to transfer or all by pressing on it which then pop up window to “copy to dual usb drive”. 

Its working well now.

:smiley:   Ok!!    Enjoy!!

Nice to see this working for you Andrias. enjoy. Lovely piece of device it is.