Extremely slow

I am trying to figure out why my SSD’s are running so slow (I purchased two 500gb Extreme SSD’s). Connected to both USB-C and USB-A 3.1 ports on an Asus Rog Strix X470-F motherboard, both types of 3.1 ports are listing the following speeds on CrystalDiskMark 6.0.2 x64:

Read:44.40MB/s

Write:43.60MB/s

These are nowhere near the advertised *Up to* 500MB/s

Is there a firmware update or something that I am missing. I truly don’t understand how they can be running so slow. Any help would be greatly appreciated.

Screen Cap from CDM of new SSD attached.

CDM-ExtremeSSD test.PNG

That is not normal.

I think SanDisk’s problems are too little that posts here just get’s ignored.

If not for the water resistance, I would have just bought an M.2 drive and put

it in an enclosure.
Untitled.png

Is that the speed you are getting from yours? Something is definitely wrong with mine if that is the case.  I can’t believe I’ve never gotten a response from Sandisk either. Lesson learned for me I guess.

1 Like

I am also having an issue with the SSD speed as it is really very slow and I am not being able to do any work through it. I was trying to get the print of a document which was stored in the SSD but due to slow, it did not happen and showed me Epson printer error code e-01.

Hi there,

I have basically the same issue with speed, it’s too low!

How can I fix it?

thanks,

Popup Wordpress Builder

Since I have come to know about the occurrence of the Lenovo Error Code 1802 in my laptop, I am noticing that whichever device I am connecting with it are getting slower. I will recommend you to go through the checking of such issue in your device. 

Are you using the included USB-C to USB-A 3.0 cable? When I use the included cable I achieve the advertised speed.

When I use another USB-C to USB-A (likely 2.0) cable I do not. I think that may be your issue.

I have an older laptop with three USB ports. Two are USB 2.0 and one is a powered USB 3.0. This drive performs slow in the USB 2.0 ports (similar to the posts below) with R/W speeds just over 40 mb/s - nowhere near the advertised rate of up to 500.

When I plug it into the USB 3.0 powered port, however, viola. Not quite 500, but I’ll take a sequential R/W 400 Mb/s on an old machine… 

-----------------------------------------------------------------------
CrystalDiskMark 6.0.2 x64 (UWP) © 2007-2018 hiyohiyo
                          Crystal Dew World : https://crystalmark.info/
-----------------------------------------------------------------------
* MB/s = 1,000,000 bytes/s [SATA/600 = 600,000,000 bytes/s]
* KB = 1000 bytes, KiB = 1024 bytes

   Sequential Read (Q= 32,T= 1) :   402.645 MB/s
  Sequential Write (Q= 32,T= 1) :   405.312 MB/s
  Random Read 4KiB (Q=  8,T= 8) :    64.634 MB/s [  15779.8 IOPS]
 Random Write 4KiB (Q=  8,T= 8) :    63.989 MB/s [  15622.3 IOPS]
  Random Read 4KiB (Q= 32,T= 1) :    28.137 MB/s [   6869.4 IOPS]
 Random Write 4KiB (Q= 32,T= 1) :    22.436 MB/s [   5477.5 IOPS]
  Random Read 4KiB (Q=  1,T= 1) :    12.494 MB/s [   3050.3 IOPS]
 Random Write 4KiB (Q=  1,T= 1) :    14.079 MB/s [   3437.3 IOPS]

  Test : 1024 MiB [E: 16.6% (77.1/465.8 GiB)] (x5)  [Interval=5 sec]
  Date : 2019/09/13 22:31:22
    OS : Windows 10  [10.0 Build 18362] (x64)
 

Yes, I think so

I too have experienced slow transfer rates (40 Megabytes per second) on USB 3.1 ports on a recently bought a 1TB SanDisk Extreme Portable SSD. I noticed that I was having slow transfer rates on all of the USB-C to USB-A cables I was using. I was however getting full speed on the supplied far-too-short cable.

I created an account here and posted this reply in case anyone else experiences the same problem as I have a solution. The problem is not with the SSD but with your cables!

After some research, I found that the majority of USB-C to USB-A cables are rated at USB 2.0 speeds which have a max transfer of 480 megabits per second or 48 Megabytes per second. Hence, the reason why we are only getting around 40 Megabytes per second transfer speeds!).

You need to ensure that your cables are USB-C to USB-A 3.0 which is also called 3.1 Gen 1. A USB-C to USB-C cable will also work as long as it too is 3.0 or 3.1 Gen 1 compliant.

USB 3.0 (also called USB 3.1 Gen 1) supports transfer speeds of up to 5 gigabits per second or 500 Megabytes per second.

You will need to buy ‘faster’ cables which can support 5gbps transfer rates. Carefully read the specifications. I am in the UK and bought some Anker and Amazon Basic cables sold through Amazon UK.

Search Amazon for either “ANKER POWERLINE+ USB C TO USB 3.0 CABLE” or “AMAZONBASICS USB TYPE-C TO TYPE-A 3.1 GEN 1 CABLE” and purchase those.  

I hope this helps! Take care!

I am trying to figure this out - using the 2 TB for media Managment on a broadcast shoot —. Friday the 2tb started slow and was going to take over 50 minutes to transfer 128gb on a fast MacBook Pro . I rebooted a few times and got it to transfer in 7 minutes . This morning I had the same issue and finally went to a standard g drive and they are transferring at the expected 18 mts -

Ps - I am using the supplied cables - to the usb 3 ports -

Extreme Pro Portable SSD.

I also have issues using the USB-A 3.1 to USB-c on my Dell Notebook (XPS 7590).

Using usb-c I get expected speed and using the same cable on USB-A 3.1 port on my desktop I also receive expected speed.  Using the supplied cables.

2020-02-15_18-20-49.png

I think it is the provided cable.  I swapped cables and now receive much better performance.

Order a usb-c to a usb-A 3.1 gen 2 cable from Amazon and will test again.

https://www.amazon.com/gp/product/B07213D35X/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1

Performance with different USB-c to USB-A cable.  I am thinking this is only a USB 3.0 cable…so performance is not max.

2020-02-15_19-58-23.png

I also have incredibly slow performance. Way worse than anything I’ve seen in this thread so far. I am using the drive to store many programming projects so that they are easy to transport back and forth between home and work. Dealing with MANY small files. Formatted as NTFS thinking that would help and nada. 

Im getting anywhere from 200kb (YES KB) to 2mb / sec. Its up and down left and right. Running it on a brand new lenovo laptop with usb-c ports - plugged directly into the usb-c ports. 

I dont know if its faulty or what - but it formats and takes the data, its just incredibly slow. I almost wish I had just grabbed a 256gb USB3 Flashdisk at this point - they are much faster than this thing.

Media Giant Design

Website Design and Marketing

Try full format

  1. Right click the drive you want to format
  2. Click FORMAT
  3. UNCHECK QUICK FORMAT option
  4. Reformat the drive (Very slow too)

There! it should work as new

got the same issue and it’s sometimes automatically fixed. how is that possible iosemus

I also went through the same situation, in fact the problem is with the cable.
Try don`t the bend the cable!