Extreme PRO SSD not compatible with iPhone 15 / iOS 17

I recently bought an iPhone 15 Pro Max and wanted to use both of my Sandisk Extreme Pro 2TB SSDs for recording video straight to SSD.

Unfortunately, I’ve discovered they’re not compatible with the iPhone 15 Pro Max.

If I run “Disk Test by Magic Benchmark”, the write test never completes to 100% - it will either lock the system or hang anywhere between 10 and 80%, and I have to unplug the SSD.
When I plug it back in, it’s not recognised.

I have two of these drives and one is recognised in the “Files” app, but still hangs when trying to write to it, and the other is only recognised AFTER the other drive has been plugged in and unplugged.

Using the Camera app, I can record less than two minutes of footage at 4k 60fps ProRes LOG before the iphone freezes completely and won’t unfreeze until I unplug the Sandisk SSD.

I’ve just bought a Samsung T7 to compare, so I can see if its my phone at fault, but that works absolutely fine.

The Sandisk SSDs also work fine on my Macbook, but just not on iPhone 15.

I’ve seen videos on youtube with people using Sandisk Extreme SSDs, but not with the Extreme PRO SSDs…

It seems there is a compatibility issue here - since I have two that don’t work.

1 Like

Hi @Junction10 ,

Have you opened a Support Case? If not opened, for more information, please contact the SD Technical Support team for best assistance and troubleshooting:

1 Like

Tengo el mismo problema, pero el disco de 1 Tera si funciona
I have the same problem, but the 1 Tera disk works

It looks like there may be a compatibility issue between the Sandisk Extreme Pro SSDs and the iPhone 15 Pro Max, since you’re experiencing issues with both drives. Incomplete write tests and a freezing issue during video recording indicate that the iPhone 15 Pro Max cannot handle the high data transfer speeds required by Sandisk Extreme Pro SSDs.

The fact that the Samsung T7 performs well on your iPhone 15 Pro Max further supports the concept of compatibility rumors with Sandisk Extreme Pro SSDs. There could be a software bug or hardware limitation on the side of the iPhone 15 Pro Max that is causing this problem. You can talk to Sandisk’s customer support team or Apple and inform them about the compatibility issues you’re experiencing with the Sandisk Extreme Pro SSDs and the iPhone 15 Pro Max.

It appears there might be a compatibility issue between the Sandisk Extreme PRO 2TB SSDs and the iPhone 15 Pro Max. The symptoms you’re describing, such as the write test hanging, the system freezing, and the drives not being recognized consistently, suggest that the iPhone is having difficulty communicating with the SSDs. This could be due to a software issue with iOS 17 or a hardware incompatibility between the specific SSD model and the iPhone’s USB-C port.

The fact that the Samsung T7 works fine with your iPhone suggests that the issue is likely specific to the Sandisk Extreme PRO SSDs. However, it’s still worth checking for any software updates on both the iPhone and the SSDs to rule out any potential software-related issues.

If you’ve already tried updating the software and the problem persists, then it’s likely a hardware compatibility issue. In this case, you may need to wait for a software update from Apple or SanDisk that addresses the compatibility issue. You could also try contacting SanDisk customer support to see if they have any known solutions or workarounds for this issue.

In the meantime, you can use the Samsung T7 as an alternative for recording video straight to an external SSD.

the fact is iphone 15pro and iphone 15pro max cannot provide enough power to drive sandisk extreme pro

Any response from Sandisk about this issue. Just need to get this work with my iPhone 15 pro max

I have a 15 pro, the 2tb SSD doesnt work, but the 1tb SSD works, STRANGE

I’ve encountered the same issue with my iPhone 15 Pro Max. I’ve tested it with five different SSDs using an RTL9210B case. After spending 4 hours testing various USB 3.2, USB4, and Thunderbolt cables, I’ve come to the conclusion that the 4.5W output on the iPhone’s USB-C port is insufficient for the 2TB SSD.

In contrast, when I tried the same 2TB SSDs with the RTL9210B case on my iPad Pro M1 and iMac 27, they worked flawlessly.