Error Using Fuze+ with Rhapsody

We just purchased two Fuze+ to use with our Rhapsody to Go subscription. One worked perfectly fine but the other keeps getting the same error. We’ve tried reformatting and updating the firmware but it still won’t work with rhapsody subscription tracks. This is the report that comes up when we check the device compatibility report: Device Compatibility Report for Sansa Fuze+ : This PC reports it is running ‘Microsoft Windows Vista , 32-bit’ This device is Rhapsody-optimized (RhapPFS) This device supports Windows Media Digital Rights Management (WMDRM) This device supports ‘WMDM_MTP’ communication protocol MTP stands for Media Transfer Protocol. This device should be compatible with Rhapsody Premier or Rhapsody Premier Plus subscriptions as it is currently configured. This device is authorized to the current user ‘___________’. ‘__________’ has a Rhapsody Premier or Rhapsody Premier Plus subscription. As configured, this device should work with Rhapsody Premier or Rhapsody Premier Plus subscriptions. Rhapsody users with a Rhapsody Premier or Rhapsody Premier Plus subscription can transfer Rhapsody subscription content to their authorized devices. You should be able to transfer subscription tracks to this device. You should be able to transfer purchased or imported tracks to this device. This device needs to have the track licenses updated. Click the ‘Update Track Licenses’ button below. This device’s secure clock failed the status request. Error codes: 0x1, 0xc00d2772. Unable to synchronize the track licenses on the device. Error codes: 0x1, 0xc00d2772.

After installing the latest firmware, on the device, go to Settings > Format and clear the device.  Be sure that the device is in MTP Mode for Rhapsody transfers.  This is found under Settings > USB Mode > MTP.

Open Rhapsody, then plug in the Fuze+, and once it appears in the sources pane of the Rhapsody client, Authorize the device.  Transfer a few new tracks from the Music Guide or your Library.  Unplug, and see that the device plays your tracks properly.

Bob  :smileyvery-happy:

We followed those steps but unfortunately we’re still getting the same error.

AArgh.  The Secure Clock issue might be the sticking point.  If the second device accepts tracks normally, the DRM cache should be OK on your PC.  The secure clock issue just may be a hardware issue.

Let’s try resetting the Secure Clock.   The WMDRM system uses a unique ID for the device, plus a timed license for the media, if it has a prescribed term of license (like a library book or subscription music).  Plug in the device in MTP mode.  And now for something completely different.  Hold the [control] and [shift] keys depressed, then with your mouse, right click on the Fuze+ in the sources pane.  Select Reset Secure Clock.

If this does not work, contact Support at 1-866-SanDisk, and let them know of your issue.  Remember to mention that you have two Fuze+ devices, and that one of them is not working properly.  Let them know of the steps you’ve tried.  It’s possible that the secure clock is malfunctioning on one of your devices.  The fact that the second device is OK shows that your computer condition is correct.  The Sansa has a one-year warranty (2 years in EU).

Bob  :smileyvery-happy:

Hi Bob,

I tried the secure clock reset and still no go. I have an email in to Sandisk Support and hope to figure it out somehow tomorrow.

The second device works fine on our daughter’s laptop PC…the problematic one is not cooperating with our desktop PC.

Thanks for your help!

I don’t think this works, I followed this step all I got is an error.:cry: