E270 problem. I need help, Im out of ideas.

Hello All,

Ill do me best to explain this and I really hope someone has an idea of what to do.

I have a 6 gig sansa E270 version 01.02.24A

My player was lagging and hanging up so I figured it was time for a fresh format. I started Rahpsody and connected my player. I then ( by right clicking ) started the format using rhapsody. Here is where things went from bad to worse. While formatting the computer I was using froze. I let it sit for about 5 hours, no dice, locked up tight. After I restarted my player and tried to play ANY song the track would appear as normal but after a second a red box would appear saying " BAD TRACK" and go to the next track only to show the same thing. So I thought I would connect to a different pc and just delete all the tracks, it was a good thought. When I connect it shoes 0 tracks but 3.3 used gig and 2.3 free and there is a yellow sign next to player. The yellow sign says I need to format the device. Ive formatted it and it still says it needs to be formatted. Ive tried updating it, no help.Using the updater it says there is not enough free space. Ive tried installing the update the manual way with no success.

Im really going NUTS without my tunes. Can someone please help.