E260 4GB SD card

My grandosn has Sansa E260 4GB and he also has a ‘mini’ 4 GB SD card. We couldn’t find any place to tell us how to use the SD card. Nothing on the small (Quick Start Guide) leaflet that came with the Sansa and nothing (that we could see) on the Sansa CD Manual.

How does the SD card work? How could he put imges/videos, etc. on the SD card (outside the Sansa) and then play them on the Sansa or transfer them to the Sansa?

Does anyone know where we could get answers to such questions? We are surprised that there was no info on the CD that came with the Sansa.

(I was sure I posted this thread this afternoon, but can’t find it in this forum. Sorry if I duplicated the post.)

Thank you

Alice

P.S. Is there some way I could contact Sansa? Have not had much luck finding an email contact,

Ver 01.02.24A

The unit may not be able to handle the card–or it may.

First, the card should say Micro on it.  Standard SD is too large. If you’re buying one, look for MicroSD.

Go to Settings, click Info and look at Version. If it starts with 1.0x.xx then it is a version 1 and the maxiimum card is 2GB–not 4. If it starts with 3 it is a version 2 and will handle the 4GB card. Cards above 2GB are microSDHC (high capacity)–something that was introduced after the v1 was made.

If your grandson is good with computers he can install an alternate firmware called Rockbox that can handle the bigger card–search for Rockbox in the search box on the upper left, or go to www.rockbox.org.

If he’s not good with computers, and you have a v1, just get a 2GB card. They’re under $10. Don’t get Kingston, which have occasional incompatibility problems with Sansa. You’re probably best with a SanDisk or Lexar card for a dollar or two more.

It goes into the slot on the upper right side of the unit with the brand name of the card facing you (copper-colored contacts on the back) and the toothed part on the top–which will probably make the card brand name upside down. You’ll feel a click when the card goes all the way into the slot, and to remove it you have to push in again to release the spring. Probably the same way it works on your cell phone, camera, etc. 

Under Settings/USB Mode put the unit in MSC mode. Connect it and you should see two drives: one for the E260 and one right after it for Removable Disc. That’s the microSD card. You can drag-and-drop music onto it. Videos need to be converted–that’s complicated and annoying,  explained in the manual. (Or you can go back to the Welcome to the Sansa Community page and look for How-to Videos).    Once they are on the card and you have disconnected, the Sansa will see them along with everything in its internal memory.

Using the card outside the Sansa depends on your computer. Some computers have slots for SD cards, and there are SD-sized converters you can slip the microSD into. One may have come with the card. Or if your computer only has USB ports, there are USB card readers. They’re cheap–about $5. 

Assuming the Sansa can handle the card, the Sansa becomes your card reader when you put it in MSC mode. 

Sansa is made by SanDisk. Contact: http://www.sandisk.com/about-sandisk/contact-us

bobbyz wrote:

How does the SD card work? How could he put imges/videos, etc. on the SD card (outside the Sansa) and then play them on the Sansa or transfer them to the Sansa?

 

P.S. Is there some way I could contact Sansa? Have not had much luck finding an email contact,

 

Ver 01.02.24A

 

According to the firmweare version you listed, this is a v1 model. Therefore, the 4GB SDHC ‘micro’ card will not be recognized by it. You will have to get a 2 GB card, which is the older SD format (as opposed to SDHC) or install Rockbox firmware, as mentioned by C1u.

You can put music files on this card, but the v1 model will not play videos from the card (sorry, don’t remember about photos); only from the internal memory. You can either put them on using an external card reader, or with it inserted in the player with the USB mode option set to MSC.

Indeed, the 4GB card, or the HC (microSD HC ) variants will only work with the v1 devices if you install Rockbox.  It might be better to stick with the 2GB cards for sake of simplicity.

That is, unless you actually have a v2 device, the last version of the e260.  Another quick way to check this is to simply turn on the machine and watch the start-up splash screen.  If the SanDisk logo has a reflection below it, and a blue sansa logo below that, you can use the 4GB cards, or microSDHC, up to the latest 32GB ones.

In your post, you mentioned “miniSD”.  We need the “micro” type for the sansa, the ones on the far left:

The little micros are teeny!

As clu31355 mentioned, if he’s adept with computers (my daughters amaze me), installing Rockbox gives the v1 plenty of new capabilities!

Bob  :smileyvery-happy:

bobbyz wrote:

My grandosn has Sansa E260 4GB and he also has a ‘mini’ 4 GB SD card.

 

Ver 01.02.24A

 

If this is the firmware version on the player, it is a v1 model which will not support the 4GB SDHC format w/o Rockbox.

Thanks everyone.

I posted the version we have in my original post - Ver 01.02.24A. Therefore, guess we cannot use the 4GB micro SD.

(I thought we might be able to update the version by downloading new version (firmware, etc.) from Sansa, that would allow us to use 4GB card, but guess not.)

Grandson did just purchase a 2GB micro SD from eBay, but I notice it says “SanDisk 2GB Micro SD Micro Mini Memory Card TF.” The “TF” I believe refers to “Transflash.” I hope he didn’t act too quickly and order the wrong thing (with TF)!

Alice

P.S.  When we look in Settings, we see nothing about SD ‘drive.’ Attahced the E260 to computer but do not see any other drive - just Sansa ‘drive.’ Guess that is because we have the 4GB SD card inserted in the Sansa, but it is not recognized.

Message Edited by bobbyz on 04-23-2010 05:26 PM

bobbyz wrote:

 

P.S.  When we look in Settings, we see nothing about SD ‘drive.’ Attahced the E260 to computer but do not see any other drive - just Sansa ‘drive.’ Guess that is because we have the 4GB SD card inserted in the Sansa, but it is not recognized.

 

Sounds more like your player is in MTP mode, rather than MSC which assigns 2 drive letters (Example - F: & G: ). The 1st one would be your player and the 2nd would be the memroy card slot. This happens whether there’s a card inserted or not.

Either that, or it’s possible you have a defective card slot which isn’t being recognized by your computer or player.

Yes, you did have the version in the original post. Sorry about that.

In Settings, USB Mode, change it to MSC and connect to your computer. See if two drives show, Sansa E260 and (next letter in the alphabet): Removable Drive.

Under Settings/Info you will see SD Drive listed if there is a (readable) card in the slot–otherwise not.

Good old Ebay listings. They probably mean Micro (does the photo look like the Micro card in Tapeworm’s pic?). Don’t worry about the TF–as long as it’s 2GB (and not a bad or counterfeit card) it should be fine.   

Thanks all.

I looked in the Settings/USB and see it is set to MSC.

I connected to notebook and saw drive F: had the Sansa, but no other drive after that. Funny thing though… For some reason I wiped both ends of USB ‘cable’ with a cloth and then reinserted and got a Windows pop-up stating "No disk in drive(no disk drive mentioned, but a small white/blank box)… and a question mark. Underneath: “Cancel / Try Again / Retry.” I clicked on Cancel and then I go the usual pop-up about how do you want to run, etc., which I closed.

But then I saw the drive G: was now showing. Maybe my cleaning off the ends of the USB cable did the ‘trick.’ I hope it did.

Think I might be spending too much time on this and will now wait to see what happens when grandson receives the 2GB micro he ordered.

Thanks so much for all your wonderful help.

Alice

SD card he ordered:

SanDisk 2GB Micro SD MicroSD Mini Memory Card TF 2 G GB

 

Message Edited by bobbyz on 04-23-2010 08:19 PM

 Sorry. Here is the image:

Alice

That’s the right card. Looks like it comes with a couple of adapters, too–SD and miniSD. Maybe your computer has a slot that takes one of them.

Just received the 2GB micro Sandisk we ordered. We put it into the Sansa and now we can see a Drive G: in Explorer (Drive F: being the Sansa). I transferred (copy/paste) some songs onto it and I could see they were transferred.
I unplugged from the USB port, but when the Sansa was turned on, I couldn’t see the new songs anywhere. The songs that were already on the Sansa were the only ones showing.

I thought as soon as I inserted the card into the Sansa, the Sansa would ‘automatically’ switch over to the card and just play the songs that were on the micro.

Should I have formatted the micro card? I didn’t think so and that is why I didn’t.
The version that shows in settings is: V1.02.24A, which I believe is latest. Set to MSC. When I insert card, it says “Refreshing Database.” And then Sansa screen opens and still original songs.
I am at a loss now as to what else to do… How to get Sansa to recognize the micro card (even though I can see it in Exploer as Drive G:.)

Alice

Add-On:

Just found the micro card on my Sanssa. I looked in the Albums and saw Unknown Album, and when I looked in there I see all the 12 songs I copy/pasted from computer to the Sansa. However, they only show as Track 1.mp3. I changed the names before the transfer, but the Track 1.mp3, etc. are still showing in the Sansa. When I attach the Sansa to the computer and look in Drive G: I see the names (of each song) as they should be.

Would you know why, when I disconnect the Sansa from computer and then look in Albums/Unknown Album and then the Track 1, Track 2, etc.?

Thanks

Message Edited by bobbyz on 04-27-2010 09:35 AM

bobbyz wrote:

Just found the micro card on my Sanssa. I looked in the Albums and saw Unknown Album, and when I looked in there I see all the 12 songs I copy/pasted from computer to the Sansa. However, they only show as Track 1.mp3. I changed the names before the transfer, but the Track 1.mp3, etc. are still showing in the Sansa. When I attach the Sansa to the computer and look in Drive G: I see the names (of each song) as they should be.

Would you know why, when I disconnect the Sansa from computer and then look in Albums/Unknown Album and then the Track 1, Track 2, etc.?

You need to edit the ID3 tags. MP3Tag is free and works great. In the Tools menu, set it to write ID3v2.3 ISO-8859-1 format and you’ll be good to go. :smiley:

Your computer sees file names, like 01-Artist-FirstSong.mp3 .

But the Sansa lists of Artist/Album, etc., are taken from electronic labels in the files called ID3 tags. Otherwise it’s Unknown because the Sansa can’t find those ID3 tags.

Mp3tag, as linked above,  will show you if those electronic labels are filled in. Otherwise, you have to fill them in yourself or get them online. 

When you install mp3tag, it asks to add itself to Context Menus. Allow that. When it installs, go to Tools/Options/Tags/Mpeg and change Write to ID3v2.3 ISO 8859-1.  Save that. Then find the album and right-click on it, and one of the options to open it wil be mp3tag. Open the album and you’ll see the list of song files. 

Either there are no tags for Artist/Album, etc., or–because there’s no fully standardized tag format–they are not in the format the Sansa reads: ID3v2.3 ISO 8859-1. (ISO 8859-1 just means Windows basic Roman alphabet.)

Most albums get tagged when they are ripped–converted to mp3. Looks like you got one that wasn’t, or has a different ID3 version. (There’s also v1, v2.1, v2.2 and v2.4.) 

If you see Artist, Album, Song Title, etc. already filled in, highlight them all and under File, Save Tag–and since you set the default, it will save them as ID3v2.3 ISO-8859-1.

If they are not filled in, leave them all highlighted and type in Album and Artist yourself, in the boxes on the left, to add it to all the files.  (Save Tag.) Then under Tag Sources try Amazon. You might be able to get all the song titles filled in automatically that way. Or try freedb, also in the list.  

Also, with the files in order, under Tools look for Auto-Numbering Wizard. Make sure they are in playing order from top to bottom, and run the Leading Zeroes option to give you track numbers 01, 02, 03, which are best for the Sansa. I do that with every album before putting it on the Sansa. It takes 2 seconds or less. 

Message Edited by c1u31355 on 04-27-2010 02:33 PM

Thank you both.

c1u31355 …   Please, what do you mean by “When it installs, go to Tools/Options/Tags/Mpeg and change Write to ID3v2.3 ISO 8859-1”?

Where is the "Tools/Options, etc.?

What is “ID3v2.3 ISO-8859-1” that is mentioned several times? Is that a program name or file name, etc.?

Alice

I should have said After you install it. Open it, look for Tools along the top and Options in the drop-down menu.

ISO-8859-1 is the way characters are put on the screen.  Your computer can handle various ways; Sansas like that one. It’s among the Options under Write. 

Thanks for all your kind help. I’ll try now to install the  Mp3tag and see what happens. I just don’t want to install a program that might damage my grandson’s computer.

I did rip an album today with the WMP10 and after some fiddling around, I got the songs onto the Sansa’s SD card along with the CD’s cover art, but just can’t get the album name to change. Oh well, at least I got the songs and artwork onto the card.

I’ll let you know how the Mp3tag installation and performance goes.

Thanks again.

Alice

(P.S. Didn’t get an email notice of your reply even though I had email reply checked, etc.)

Message Edited by bobbyz on 04-29-2010 08:23 PM

Normally, WiMP 10 will pull the album art and data automatically during the rip, as long as you have an active internet connection.  If it doesn’t, right click on the album image if blank (Library view), and select find album info.

A wizard will pop up, and you can go from there.  Once everything is updated, the ID3tag will be written in ID3v2.3 ISO8859-1 format as well.

If you choose to edit the tags using MP3Tag, once you select “write” to this format, all albums will automatically be written inb the correct format for you.

Feel free at ask here if you run into any hurdles!

Bob  :smileyvery-happy:

Thank you.

I did install the MP3tag and f9und it quite nice to use. However, there is one thing that continues to trouble us. One or two of the albums will not allow us to change their Album Name. We’ve tried everything we can think of (grandson and me).

When we look in the Sansa on the computer, it has the Album title we want, and when we look in th MP3tag, we see the correct title. However, when we look in the Sansa itself, we see the long title that we do not want.

CD title shows in Sansa: Among My Souvenirs.   In our computer Windows Explorer, it shows the way we want it to show: Connie Francis.

(Grandson put a few songs on the Sansa for me and his grandfather, and when we look in albums we would rather see Connie Francis (which let us know whose album it is), rather than “Amoung My Souvenirs” which doesn’t tell us who the singer is.

Another one shows in Sansa as: "The Ultimate Collection - Stand By Me -Best of Ben E. King/Ben E King with the Drifters.

Windows Explorer folder shows: Ben E. King (which is what we want)

Any ideas how to have Sansa show the album name the way we want?

Thank you for any help.

Alice

(P.S. Our WMP 10 is not copying the album info and art when we rip. Maybe something I am doing wrong. All very new to me, as you can tell.)

Interesting!  WiMP 10 should do the tag automatically, including the album art.  Yoiu could try the si,plest upgrade, go to Help > Check For Updates, and upgrade to WiMP 11.  I’ve found it to be a bit smoother than WiMP 10.

On the other side of the coin, running with Windows 7, WiMP 12 is kludgy in comparison, as the “Advanced Tag Editor” is hidden, and the player is problematic when ripping / editing the tag data.  The latest player mated with Windows 7 only, using the new file display format.  Microsoft integrated most functions in the background, making manual adjustments a real treat.

Bob  :wink: