downloading audio books

I’ve listened to all of the books I had on my Sansa Clip and have deleted them. When I downloaded 5 more books to my iMac and then tried to drop them in my AUDIOBOOKS folder on my player, I got the following message: “The item [book title] can’t be copied because there isn’t enough space.” This book has 27 chapters, each one of which is only 64 kb, all mp3 files. My Sansa Clip is set to MSC mode. I have only a few tunes on my playe, so they can’t be the culprit. I previously had 7 or 8 books on it and they loaded with no problem. I was able to load the first 6 chapters of the new book before the warning message popped up again. I have now deleted the first 3 chapters after listening to them, and I get the warning message when I try to load chapter 7. Help please!

Could be a few things.

1.  When Macs are used with non-Apple peripherals, they create “ghost” files on the peripheral which can choke the peripheral.  Software like freeware Hidden Cleaner to transfer files can avoid this.

2.  More likely, my understanding (as a non-Mac guy) is that the Mac trash has to be emptied, for deleted files to be truly deleted; otherwise, they still occupy space.  You might try that.  

Just to further isolate the issue since it was not posted. Is this behaviour the same when you used a PC instead of  a MAC? 

Thanks, Milkerman, your suggestions will give me a starting place, at least.

Sorry Hirsche, I’ve never used a PC—Mac-only since my old Kaypro with CP/M OS bit the dust in about 1986.

Emptying my iMac trash had no effect. I tried to download Hidden Cleaner twice, but when I tried to open the install, I was told both times it was damaged and could not be opened.

Did you empty the trash with the Sansa connected?

hirsche is not generally a reliable source but if you know anyone with a PC, you could try connecting. Doublecheck that it’s on MSC mode so Windows Media Player doesn’t get involved.

You also might try another source for Hidden Cleaner. Available at many sources on the web.