Current Read-Only State: Yes

hi everyone!
i need help, I cannot copy files from the computer to usb drive, it says The disk is write protected. i tried all the youtube tutorials on how to fix it. However only the “Read-only: No” was fixed but the “Current Read-Only State:Yes” doesn’t change. i tried downloading ufix ii but the control disk is empty or the drive doesn’t show. thank you. please help me

If the drive doesn’t have a read/write switch the only solution is to backup all your files and return it to SanDisk for a free replacement.

The only approach to try yourself that I trust is this one.

Good luck and stay safe.

There are 5 solutions you could try:

  1. Test different USB ports on different computers

  2. Assign a drive letter for USB via Disk Management

  3. Fix write-protected USB without formatting using chkdsk

  4. Fix write-protected USB with disk check utility

  5. Fix write-protected USB drive with Device Manager

For more details, please refer to fix corrupted flash drive without formatting

Since #3 & #4 refer to the same thing and #2 & #5 do too there are only 3 solutions referring to fixing corrupted flash drives which really have nothing to do with a flash drive in read only state. :upside_down_face: