Cruzer Facet 32Gb suddenly became a read-only disk

Hello everybody,

I bougth 2 months ago a Sandisk Cruzer Facet 32Gb usb stick. I was using 2 partitions on it but suddenly it became unusable.

It looks like I turned the hardware R/W switch but there 's no harderware switch.

I cannot even delete the partitions. I tried to do it on Win Xp and 764b, on mac os x and on gparted (linux). Same problem.

this is what I get on diskpart:

DISKPART> attributes disk
Current Read-only State : Yes
Read-only : Noa
Boot Disk : No
Pagefile Disk : No
Hibernation File Disk : No
Crashdump Disk : No
Clustered Disk : No

it is identified as Disk 1 and the GPT flag is active

DISKPART> list disk

Disk ### Status Size Free Dyn Gpt
-------- ------------- ------- ------- — ---
Disk 0 Online 119 GB 0 B
Disk 1 Online 29 GB 1024 KB

My two partition are shown as follow:

DISKPART> list partition

Partition ### Type Size Offset
------------- ---------------- ------- -------
* Partition 1 Primary 28 GB 1024 KB
Partition 2 Primary 999 MB 28 GB

there are two volumes, one of them is hidden (I did it so) and filesystem is raw because it is encrypted with Truecrypt.

DISKPART> list volume

Volume ### Ltr Label Fs Type Size Status Info
---------- — ----------- ----- ---------- ------- --------- --------
* Volume 2 RAW Partition 28 GB Healthy Hidden
Volume 3 TT32 NTFS Partition 999 MB Healthy

Every command I run is ignored and I get the following error:

DiskPart has encountered an error: The media is write protected.
See the System Event Log for more information.

I wonder what to do. It looks damaged. I read that lot’s of people have the same issue. Any idea?

I read that lot’s of people have the same issue. Any idea?”

Did you read what those people were told to do? 

1 Like

Is there a way to turn off the write protect?  A 32G flash drive does no good if  I have 20G of space left and cant write to it.

There is no known way. You should return the flash drive. If under warranty SanDisk will replace it for free.

1 Like