Cruzer Blade 16GB doesn't work in a particular machine

Hi,

I bought a Cruzer Blade 16GB USB stick from Amazon (UK) yesterday and although it worked fine on my (Windows 7SP1 Professional 64 bit) workstation at work, and even on my (Android) phone and tablet, I’m having problems using it on my main home PC (Win 7SP1 Professional 64bit)

The drivers appeared to install correctly, but it takes quite some time to appear in Windows Explorer as drive “H:” in the “Devices with removable storage” section of My Computer, and when it does, the volume appears unmounted and I can’t actually do anything with it.  I see no errors in Device Manager.  Selecting the device properties, under the “Volumes” tab, it says “no media”.  The stick only sometimes registers itself in Device Manager as the drive letter under “Portable Devices”.  I’ve tried uninstalling the “Sandisk Cruzer Blade USB Device” driver and, when it appears, the “H:” device in “Portable Devices” with no luck.

If it matters, the only other USB devices that I have regularly plugged in to my computer (apart from the keyboard and mouse) are an iPod Touch and my phone (Samsung Galaxy S2).

Does anyone have any ideas?

Thanks,

Raj.

Ah, never mind.  I appear to have found the solution on the forum here.

Killing the Kies Tray Agent task in Task Manger seems to have solved the problem.  That is somewhat weird.  It’s not ideal, but it’ll do as a workaround :).

Thanks anyway,

Raj.

how did it work?? i have the same problem and it’s not working!!! please help me!!!

I just opened Task Manager (press 'Ctrl-Alt-Delete, click “Start Task Manager”) and from the list of processes selected KiesTrayAgent.exe and clicked the “End Process” button. Note: this should be done with the Cruzer USB stick unplugged. Once the process disappeared from the list, I just plugged it in and it appeared in Windows Explorer.