Cruzer 16GB USB drive - "Windows Explorer has stopped working."

I just bought 4 of these drives to use for backups.

I am running Windows 7 Home Premium 64-bit with 6GB RAM on a Dell Studio D540.

I have Autoplay turned off.

When I insert the drive in the USB port, the driver software installs and all seems fine. When I then go to Windows Explorer and try to either read the properties of the drive or format the drive (I’d like to make it exFAT to accomodate a large ZIP file - (I use WinZip Pro for backing up) -  up pops a window stating that “Windows Explorer has stopped working”. It then tries to “find a solution” and nothing further happens - except that Windows Explorer then proceeds to close.

I tried Googling for a way to fix the problem and also searched on the Sandisk website and in this forum, but no joy.

Other odd thing - I can access the files that came loaded on the drive and can even run them from Windows Explorer. I just cannot view the drive properties or format the drive.

Does anyone have a suggestion as to how I can fix this problem?

Worst case scenario - I’ll just install the Sandisk encryption software and back up the files using another method besides WinZip. I would rather, though, find out first what is preventing me from doing what I thought would be a simple task.

BTW, I tried out 2 of the 4 drives so the issue does not seem specific to a single drive.

Really interesting. First thing you need to do is isolate. try this in other computers if it behaves the same. If yes, you might want to consider the warranty on this.

I tried one of the drives (same one that did not work on this PC) on another PC also running Win 7 - I was able to access Properties and Format under Windows Explorer so it appears to be a problem with something on this particular PC.

So it looks like the problem is not with the drives themselves.

I am running Bitdefender Total Security 2013 as my antimalware program. I disabled both the firewall and the antivirus - still no joy.

The problem appears then to be something that is running on this PC that is not running on the other PC - or vice versa - or a particular setting somewhere.

This stuff can really make you crazy.  :confounded:

well i am sure antivirus is not the problem
try other usb drive products test they react same if doesnt try uninstalling the your drive drives and plug them to install them again

I have already spent WAY too much time on this problem - extremely frustrating. I managed to get one of the drives formatted to exFAT through the Computer Management Administrative Tool - or so I thought. Now my PC does not even recognize the drive - I get an error 43 message and can do nothing with the drive. The indicator light on the drive doesn’t even light up.

I have tried unplugging all USB devices (except the mouse), uninstalling all of the USB Host Controllers in Device Manager (except for the one that runs the mouse - I needed at least one input device to work so I could shut down the machine gracefully), then shut the machine off, pulled the power plug from the UPS, waited 5 minutes, held the power button down for 30 seconds, plugged the power cord back in, and restarted the machine. The PC started to reinstall all of the deleted USB Host Controllers. Then I plugged the USB devices back in, one by one.

Didn’t fix the problem.   :angry:

Some interesting things that I noted - the drive that did NOT get hosed (still FAT32), I can access Properties in Windows Explorer if I click on the drive, click on the Organize menu item and go to Properties (I had not tried that earlier). If I try to go to Properties via a right click as before, though, Windows Explorer still bombs out. Also, when I go to eject this drive, the option refers to the drive as a “Firebird” drive. Once it is ejected, it then calls it a “Cruzer” drive. Weird.

And yes, I have run System File Checker from the command line with SFC /scannow - it reports finding no problems.

Reformating rarely is a fix.

If new try to return it to the place you bought it.  If unable see about sending it to SanDisk for a replacement.

@power2233 wrote:

well i am sure antivirus is not the problem
try other usb drive products test they react same if doesnt try uninstalling the your drive drives and plug them to install them again

Actually, it turns out the problem WAS my antivirus.  Strange because I had turned it off at certain points in my lengthy journey through PC hell and had therefore ruled it out in my mind as the cause.

It wasn’t until about an hour ago when I changed my search from USB drive problems to right-click options causing Windows Explorer to crash that I caught a glimpse of a possible fix. From that I got a link to the Bitdefender forums where it described my exact problem. Here’s the link:

The solution involved changing some drive-scanning options in the program (which I had already done) and downloading and running a REG file to edit the Windows Registry. After rebooting I tried the right-click option to access Properties on the working USB drive and - it worked!

Now if anyone can suggest a way to reformat my nonfunctioning USB drive (mentioned in my earlier posts), I will be back in business. The bloody thing doesn’t even show up in Windows Explorer or Disk management. It’s hard to format a drive that is invisible to the system.  :wink:

It’s hard to format a drive that is invisible to the system.”

It’s equally hard to format a drive that is burned out.  Or shorted out.  Easier to send it back for a replacement.  Either to where you bought it or to SanDisk via an RMA.

I sent the dead drive back to SanDisk for a replacement earlier today.

I dropped off the dead drive with the prepaid shipping label from UPS on Jan. 5 and the new drive was shipped back to me by SanDisk on Jan. 11. So any day now I should have a new replacement drive.

Thank you, SanDisk!

I had the exact same problem.

I noticed that when I first plugged in the USB drive, Explorer got sluggish. But it didn’t hang until after I’d managed to open a File Explorer Window. While that was open, I could see my files. Then Explorer hung.

After a while, Explorer came back. The File Exporer view of the drive was now empty, as if the stick had nothing on it… I tried removing and re-inserting it, with the same effect – I could see the files at first, then not.

I plugged the drive into a Mac. Thankfully, it can’t run Windows apps. Using the Finder, I deleted the SanDisk Club_application folder, and the SanDiskSecureAccess application. Then I went back to the Windows machine, and everything worked fine.

So, note to SanDisk: your extra unwanted applications appear to be the cause.

Were you executing either of the SanDisk apps?  Microsoft disabled autorun on all removable drives since XP SP3.