Windows 7 Explorer not showing drive while it shows in computer management


I have 3 SanDisk Cruzer thumbdrives which have worked flawlessly up until the other day.  I have 2 windows 7 computers with one computer still reading the drives with no problems while the other computer now sporadically reads them.  The cruzer drives work flawlessly on an XP computer so I know the Cruzers are not broken.

The computer that doesn’t read the cruzers still reads my other flash drives such as a Lexar and an older Sandisk 16 GB (2008-9 version) with no problems.  The problem only seems to be with the newer cruzers on this computer.

Looking at computer management the cruzer drives show up in disk drives and portable devices.  In portable devices they show up with the correct letter.  In disk management however they do not show up.  They also do not show up in explorer however if I type the drive letter in  it goes to the drive but it cannot read anything with no files showing.  If I try to create a directory it say the device has been removed.

I have changed the letter of the drive but this does not bring it up in explorer.

The only thing I have done is to connect a  new Samsung Galaxxy 10.1 Tab 2 to this computer and install Kies.  I wonder if this would couse the problem.

Maybe the solution is to buy Lexar?

Any comments appreciated.



It is possible the machine having problems has a weak power supply or multiple USB devices attached.

It is also possible the machine’s USB port has an oxidized connection.  If so it can be cleaned very gently with a piece of emory paper.


I have the same problem, exactly. I’m running windows 7 on a brand new laptop. I installed samsung keis and the storage device still worked, I installed ny HP printer and it still worked but soon after that it stopped neing recongnised in the explorer window but shows in the devices screen.

Could it be that the device is a 32 bit and the my Windows 7 is 64 bit?

Please help!!1

Could it be that the device is a 32 bit and the my Windows 7 is 64 bit?”

Unlikely.  Device drivers come with the OS.  I suspect your problem is multiple devices trying to use the same device letter.  Change the USB drive to something further down the line like U (for USB device) and see if that helps after you reboot.

Same issue here, I can see Cruzer Fit under disk drives in device manager. (Win 7 x64).

It used to work before I added kies?

WinXP still can see it.

There is some kies interaction with sandisk usb

Quick fix - Open task manager, Kill Kies and Kies agent - now it works!

Kies version 2012-10-11 2,5,12094-28

I have a similar issue.  I can’t load a 16G cruzer.  It eventually shows up in explorer with a drive letter, but can’t access the drive.  Device manager shows the WPD driver associated with the drive letter can’t start (code 10).  Computer management hangs when I try to look there.  Killing the Kies trayagent (same version as above) solves the problem.  Interesting thing is that a 4G cruzer works fine with the Kies agent running.  Going to research this some more.

Same problem with new Windows 7 64-bit computer. Not recognizing the kies program abbreviation, pulled up task manager and could see nothing similar. Suggestions?

Massive thanks Lukasz, I was having the same problem and killing the Kies processes fixed it for me. Tearing my hair out, because it works totally fine in a different PC! Samsung strikes again :frowning:

I am having the exact same problem after installing Kies on one of my laptops window 7 .on my other laptop window 7 no issue t . I uninstalled kies and now it works again. For me I need Kies so I will just buy sony humbdrives for now on. (( PS the older version Sandisk does work with kies.)) I spent hours and hours trying to figure out how to make the 8 g sandisk work with samsung Kies but could not let me know if you figure it out. Thanks


only SANDISK cruzer switch and blade pendrives were not working on only Samsung Laptop. Other USB drives were working on the same laptop and the same SANDISK USB drives were working on other laptops and PCs including MAC.

As soon as I Killed all Kies processes on the SAMSUNG laptop, the pendrives started working.

I guess there is some clash between SANDISK driver and Kies programs.

Open task manager, Kill Kies and Kies agent - reinsert usb drive and it should work.

So far I had issues with: Kies and Sony’s camera PlayMemories Home software.

This issue was reported however the compatibility lab states no issue was found. For those of your experiencing the issue could you post the technology code printed on the drives. It will start with 2 letters followed by a series of numbers and letters. It is printed along with the part number and country of origin. 

Forum Admin


I’ve just got a 16Gb Cruzer fit today and had this exact problem. Killing the kies processes sorted it out.

My technology code from the cruzer is BL121023298V

It is definitely Kies. I tried everthing to get my 2-32gb Cruzers to work on my win7 pc and nothing.

Saw the Kies post here and removed Kies with Revo Unistaller. Both drives working perfectly now.

Thanks to the person that figured the Kies solution. Iwould never have expected it.

Knocking out Kies via task manager worked for me… wish I found this thread 2 hours ago!!!.. 

Anyone know why this is occuring?

Anyone know why this is occuring?”

Not having Kies I can only guess but does Kies get assigned a drive letter when it is active?  If so it is possible that Windows is assigning the same drive letter to the USB flask drive, which of course won’t work.

Thanks so much for figuring it out that Kies was the problem.  I have been afraid that I was developing some serious issues with my new laptop.  All of my usb drives were afftected one way or another.  Some, like the SanDisks were not connecting at all, some very slowly.  It was scary.  After removing Kies, all is normal again.  I’ll have to decide if it’s worth having Kies.  I can connect wirelessly to my Tab 10.1, and maybe that will do.


Thank you, thank you!:smiley:

I had the same problem. It did not work on my USB 2 or USB 3 ports on a computer with Kies installed. Once uninstalled it worked. It also works on another computer without Kies.

The number on the Cruzer Fit is: BL120723298V

The same problem and the same solution.After killing Kies process Cruze Edger 32 gb is detected and works fine(The number on the Cruzer Fit is: BM1208ZNBB)