Costco SSD Extreme 1TB - Secureaccess v3.01 factory program problems & lost files (encrypted)

My experience with Sandisksecureaccess thus far …

Installed the factory exe Sandisksecureaccess v3.01 on the drive and proceeded to load files onto it.
Everything worked as promised. After a while the app became slow and then refused to open at all. Right after password the app would crash or would time out. I was never able to access the app menu again. I tried the drive on a macbook pro and also a windows 7 pc with no such luck. Searched the forums and tried multiple fixes & suggestions - no such luck.
**Each time I disconnected the drive properly (ejected) and never had a crash.

After all things failed I then transferred all contents of the UFD onto a backup HD - I saved all folders and copied the vault over intact. I didn’t modify or rename any of the original folder names.
I then Installed the original 3.01 software it shipped with (same password) and copied all folders back to the UFD drive (vault). It wrote over all the files or replaced the existing ones. Once launched I could not see any of my encrypted folders in the vault. Repairing made the app crash or time out.

Are these encypted files gone for good or is there a way to reverse the process by means of decryption ??

I have tried v1,v2, and version 3 (doubt they would work anyways as encryption is different?). I tried to format using exfat and NTFS to see if that fixed the bug.

I’m all out of ideas and wondering if these important files are lost forever??

Current Conclusion:
Sandisksecureaccess made my files so secure I can’t ever access them again…

Hi @SSD1,

Please refer below link to contact proper support team for resolution:

Hope it helps!!