Connect to Drive & Internet not working

The requirement is to set the SanDisk Wireless Network device up to be connected to my home WPA2-Personal 2.4Ghz 802.11n wireless network, in order for me to connect to it via name or IP to transfer files. This is in preference to selecting the built-in network connection every time I want to connect to the device.

Steps I’ve tried

  1. Successfully connected to the device using Windows 10 and Chrome browser, on it’s own SanDisk Connect wireless AP.

Able to add files and folders, but when attempting to select ‘Settings’ receive ‘This site can’t be reached’ using URL  when attempting to configure settings. Previously was able to connect to it, but unable to configure anything but the Wireless security type, not as hoped, the option to allow it to connect to the home wireless AP as a node.

Abandoning the web interface as potentially buggy as inconsistently opening settings, and even when open, not having full functionality, moved to the Android App:

Prerequisites for testing

Install latest SanDisk Android app

Hard Reset SanDisk 32GB device, with an open network, fully charged switched on.

Phone recognises the Sandisk Wireless network.

  1. Open the App, and attempt to connect to the device
  2. ‘How would you like to connect’ is shown, and ‘Connect to Drive’ or ‘Access Drive & Internet - Connect’ options.

Note: Selecting the < Back button results in a Please Wait…  loop never progressing. Kill the app and start again.

  • Connect to Drive
  1. Sandisk Connect Fxxxx Connecting…. (Wait about 45 seconds)
  2. Select which drive you’d like to connect to ‘Sandisk Connect… 15.9gb etc.’
  3. Simply selecting the drive you’d like to connect to results in a loop.
  4. Press and hold, and select Home Network Mode
  5. Opens the Contents … page, after about 10 seconds displays ‘Drive not connected’.
  6. If showing ‘Drive not connected’, start from beginning.
  7. <Sigh>
  8. (Alternate option) Press and hold, and select AP Mode
  9. Displays ‘SanDisk Connect Fxxxxx Connecting…’ Returns to ‘Select the drive’ page loop. Start from the beginning.
  10. Access Drive and Internet Connec t…
  11. Displays ‘Scanning your wireless Network’ wait…
  12. ‘No drives found’… Connect to drive (Access Drive Only method)
  13. See steps 2 onward.
  14. Repeat all steps in various orders multiple times, throw phone and device at wall, and pity other users.
  15. Ensure both phone and device are okay, try all the steps again while writing testing documentation.
  16. Consult forums, find nothing, post steps and go to bed after midnight in the vain hope that someone else has had and overcome this particular issue.
1 Like

Wow that sounds just like what I’ve been going through with my 200GB Connect Drive…connected, disconnected, connected, disconnect, connected, select WiFi for internet, enter password, disconnected, welcome to sandisk, repeat…did u ever get anything worked out with yours??

You have my sympathy, I eventually discovered that it was an issue with using my old Android device. So I purchased a new Android touchpad, and it allowed me to set it up without much fuss.

It’s a shame that it doesn’t work like a NAS, I’m still on the hunt for one which just connects to my existing wireless network when switched on, allowing me to copy data to it, then use the USB to access that data on other non-wifi devices, without acting as a separate independant wireless hub.