Clip+ trash characters in folder option help?

I just got my Clip+ to replace my recently dead (and much beloved) Muvo Tx Fm.  So far I’m pretty happy with it.  I have come across one problem though.

The reason I loved the Muvo (and bought the Clip+) was because I didn’t want to screw with any stupid software.  I keep my .mp3 players sorted on my computer by Artist Name/Album (with the albums being labeled by the year they were released). 

So I copied over a bunch of albums to my new Clip+ today and of the 50, a good 45ish were fine.  But a few had corrupted folder names, which made it hard to see what they were, and difficult to find.  For example - my REM album’s should look thusly:

1982 Chronic Town

1983  Murmur

1984  Reckoning

1985 Fables of the Reconstruction

But Fables is corrupted for some reason.  And shows up on the player liks this: “29000000 1985 Fables of the Reconstruction.”  Obviously the 29 million isn’t actually in the folder name I copied over.  A few other albums are likewise corrupted with giant numbers.  So that when I preuse the folders directory they are all placed at the very end, and I have to pause on them so the player scrolls over to reveal the actual name. 

It’s not a dealbreaker by any means, but it is an annoying and curious error.   Does anyone have any ideas on what causes it, or how to fix it?  Thanks!

Try switching the Clip’s USB mode, under the player’s settings, to MSC.  That should do the trick. 

1 Like

Sounds like you used MTP mode to transfer the files. Use MSC instead.

That did indeed fix it - thanks guys!  Under my settings the USB mode was set to “auto detect” any idea why it would choose one over the other, or what the purpose of the dual modes is to begin with (just out of curiousity). 

Thanks again!

Auto Defect defaults to MTP mode, needed for DRM-encrypted files (Rhapsody, Audible, Napster, etc.). MSC mode makes your device appear as any other ‘dumb’ storage drive (like thumb drive, memory stick, etc.)

@tapeworm wrote:

Sounds like you used MTP mode to transfer the files. Use MSC instead.

Yep–that’s why I said it directly above your post.   :wink:

@miikerman wrote:


@tapeworm wrote:

Sounds like you used MTP mode to transfer the files. Use MSC instead.


Yep–that’s why I said it directly above your post.   :wink:

Great minds do think alike (and at the same time too) don’t they? :smiley:

Seems we were both composing our response at the same time. I got called away and didn’t get mine posted until after yours though. I decided to leave it as further reinforcement of what you already had said. :stuck_out_tongue:

I always can use the validation in life! :wink: