Clip+ 8GB freeze on startup


My only one month old Sansa Clip+ 8GB freezes on the startup screen and nothing happens when I try to connect t to the PC either.

I’ve tried to reset it several times and also tried to hold down the center button when connecting to PC, but nothing has worked.

When I try to turn it on it first shows the Sansa screen, which then turns into the four-leaf clover. But then it starts with the same procedure all over again, until it freezes on the four-leaf clover screen. It does a double start-up and then freezes.

Any ideas on what to do?

It could be that you loaded a bad file to it. Kinda odd that nothing still happens when you connect it to the PC while holding the center button. Turn off the Sansa first, then connect it while holding the center and dont let go until it gets recognized under My Computer. It should show up under My Computer with a driver letter. Right click on it and select on format. Once you’re done formatting it, download this and extract it to the root directory of the clip +. Unplug it and cross your fingers. :wink:

No need to download the firmware file noted in the previous thread, if the reformat fixes matters.  Although reapplying the firmware can fix a possible firmware code corruption issue, if the problem remains. 

No need to download the firmware file noted in the previous comment, if the reformat fixes matters.  Although reapplying the firmware can fix a possible firmware code corruption issue, if the problem remains.

It still freezes and nothing happens, no matter how long I keep holding the center button down.

I recently started having this problem with my Clip+ 4GB. No combination of buttons has worked and I’ve tried plugging into two different computers on 3 different operating systems. The last time I got it to work I had it in MSC mode so I could use it in Ubuntu 10.10. I copied a couple songs onto it and ejected and unplugged it. I worked fine for a day or so and now it will show the Sansa/Flower splash screen twice before hanging on the flower screen. I does turn itself off after a few minutes though.  So far this is the only place I’ve seen where someone has had the same problem.

Any suggestions? Has anyone else had this problem? It’s still in warranty but I really don’t want to have to send it off.


I’m refreshing this topic. I have exactly the same problem, the sansa logo pops up twice then freezes on the flower. I’ve also tried the button combination, but the + model doesn’t have the ‘lock’ button. Someone solved this somehow? I just got my clip and I need it for work…

That may let you get far enough into booting to reformat from the player’s settings menu.

Did you try a simple reset of the player, when it locks, to see if that helps? (Hold the on button down for 20-30 seconds, or more.)

That’s exactly what I have to do, but this method isn’t working either.

About the soft reset… Yes. Of course I’ve tried it, that’s the first thing anyone will do (thanks for your reply Miikermanbut it’s kind of irritating that everyone ask this at least 3 times per thread)

Sorry to have asked but, things happen to the best of us (and best to check out the basics, it seems to me) . . . . You might be surprised by the number of people who don’t know about the soft reset (even though it’s in the manual) or who think they have a defective player because of screen issues, when they haven’t take the screen protective plastic off a new player. :wink:

As discussed above, have you also already reformatted the player using Windows? And reinstalled the latest firmware onto the Clip (the firmare can become corrupt) (see the firmware upgrade sticky thread at the top of the forum)? You also could try running a Windows error check (chkdsk) on the Clip drive (right click on the Clip drive from Windows, choose Properties, and then look for the error checking option–be sure to tick off the box to allow the fixing of any errors). Again, some basic things to try, if you haven’t already (am not quite sure of the extent of what you already have done).

I would very much like to, but as I said my problem is the same as this thread’s author. It simply freezes after showing sansa logo two times, it must be because of some corrupted files (it happened just after I’ve inserted new 16gb minisd) and I can’t acces menu to format it trough the player. It acts exatly the same after connecting to usb, and so I can’t read (and format) it trough pc.

Anyway you’re right about my previous comment. I mean, sure, you have to cover the basics and eliminate most common cases.

And I’m assuming that the startup issue, including when you connect to your computer via USB, also is preventing you from running a Windows error check on the player. You mentioned possible corrupted files on the microSD card–have you tried the various above measures with the SD card removed? (I’m really hoping that might do the trick.) And then I’d reformat the card from your computer (assuming that you don’t mind losing the card’s content–if that’s an issue and you can, transfer the content to your computer first). And then tread carefully in putting content back on the card, seeing if you can identify the possibly corrupt files. And, of course, you might have already done all of the above . . . .

(Perhaps of course, remove the microSD card when the player is off.)

Mhm, before posting I’ve tried turning it on with/without sdcard; pluged\unpluged to usb; locked/unlocked in every combination, also while on and off… It seems quite hopeless. Och and I don’t need any files either from the player or the card. Fortunatelly I still have warrancy on it, so that’ll have to do. No audiobooks for me tomorrow. Still, thanks for the support.

Ouch. I just can’t figure out how you can get “into” the Clip to fix it, if you can’t get it beyond the opening logo any which way. Since you need to do it anyway for a warranty replacement, time to check in with SanDisk customer service (by phone is best) to see if they have an idea around the opening freeze? I wonder if I’m just not recalling a solution there.

im guessing there no wayof fixing this then?

@spm12 wrote:

im guessing there no wayof fixing this then?

Fixing what?

You tagged onto a 2 year old thread that may or may not be pertinent to your situation. If you’re having a problem, start a new thread (message) and give as many details as you can about the issue, when it started, your player, your computer OS, your files (format, bit-rate, etc.), anything you can think of that would help someone help you.