CFast 2.0 Card Disappearing Images????

Hello, I am a professional photographer and have a relatively new Canon 1Dx Mark II and Sandisk CFast 2.0 64GB memory card that I have been using for several months without issues until yesterday. I was shooting a swim meet and occastionally reviewing my images from the card while the card was still in the camera throughout the day. I went to download my images and found only 116 images on the card when there should have been hundreds more. I downloaded those using Lightroom, like I always do. I ejected the card, rebooted my computer and then tried to import again hoping hte missing images would show up. The card now shows NO images on it. I NEVER have had this happen before as I do not erase or format my cards until my next shoot just in case of issues. 

When the card was new I used the Sandisk CFast tool to format the card. since then I have only formatted the card in my camera. 

I just spent $40 on “RescuePro” which either crashes or does not see any images to recover. I have been a Sandisk pro memory card user for over 10 years after I was let down by Lexar pro cards. To say I am dissapointed is an understatement right now. ANY help would be appreciated!

Sandisk support offered to replace the card only saying images are corrupted. I was able to recover my missing images using Stellar Phoenix Photo Recovery software. 


Agreed with KCFP, the software worked for me too! Really easy to work with.