CF card undetectable on Mac after formatting in camera.

Hi everyone.

I use a Nikon D700 and Sandisk Extreme 16gb card, with a Lexar Dual Slot card reader for importing.

This morning I imported all of my photos to my Mac, removed the card, put it in my camera and formatted it (this is the first time i have formatted it.)

I took photos this evening and when I returned home I was unable to import anything. The blue light appears on the Lexar reader but nothing happens on computer. Lexar is reading SD cards fine still, so I assume the problem is with my card. 

When I put the card back into my camera all the photos appear as normal and I am still able to take photos. 

I have tried using a USB cable to connect the camera, and nothing happens. 

Does anybody know what could be causing this? Could it be that I broke my card by formatting it?! 

Have you tried using the card with another Mac or PC? If so, save the pictures somewhere and reformat it. may be formatting changed the data type of the card.