Can't log in to my Ebox account??

When I try to log in to my Ebox account to print out my UPS label  I get: Either your login name or password was incorrect.

I had it send me off a email with my log in and password and I entered  that info in to the site but I still get  the same thing.

I called Sandisk, and they said they would send it up to get looked into next thing I know I get a email with my login and password, and my RMA number but I still can’t log in to the site.

Can someone help me with this?

Message Edited by lee78221 on 02-27-2008 05:26 AM

Message Edited by lee78221 on 02-27-2008 05:29 AM

As per your case notes, and the call you have already made. Your case is being looked into so that we can provide you the correct login information. You should get a response by the end of today, worry not.

Best Regards,

Sansa Forum Team

Thanks a million.

I was wondering why when I attempt to login to my Ebox off the sandisk website, the screen remains blink and never continue to my destination.  I attempted this on three different computers, worked once but, never again after that.  Its important for me to access my account to check the status of my RMA and my replacement Sansa E280 8g mp3 player.

In going through your case, you have already contacted us on April First. The RMA department, according to the case notes, has provided all the information you seek.

I am unsure what other information you are looking for.

The standard return rate is anywhere between 7-10 business days from when we obtain the original (and presumably defective) device. It can also be tracked via UPS using the tracking number provided to you. If you are having trouble obtaining that tracking number, please feel free to call the RMA department and have one of our agents provide this number for you. (after verifying indentity)

Message Edited by MrSmileyFace on 04-02-2008 09:37 AM

 I have a question about the online-support and Ebox

When i try register a product and being asked to log in to the ebox, and succesfully do (i think atleast?)

then i dont understand how i shall get pass this afterfollowing screen

http://img3.imagebanana.com/img/5fhv9ckt/bananaboris_FullScreen.jpg

how do i get to the accually online-support? anything related to the support traps me at this screen in the outcome…i dont know what you want me to do here basicly :) klicking on any of the 4 red links in my picture doesnt get me anywhere further into the product registration?

Message Edited by Kloppstock on 04-03-2008 05:05 AM

the link you provided does not work.

and from my understanding, you dont have to do all that. Just email support@sandisk.com

I can’t log into my Ebox account either. When I click on the link that was in my email from Sansa, I get nothing, a blank page, says “Done” on the bottom left. However, there is a padlock next to the url on the top. I assume this means something is locked. When I click on the padlock, it brings up a message that says “This connection to the server is encrypted” and then lower down “View certificates”. I then clicked on install certificate (Info about the certificate:Ensures the identity of a remote computer) but that didn’t help. So what do I do now?

all the lock sign means is that it is a SSL webpage and the internet traffic is encrypted.

try using this link. then click on the my ebox tab and enter your information

This link didn’t work either. I just get a blank page and in the lower left corner it says Done.

The link they sent to me also does not work. I get a blank screen with the word “Done” in the bottom left corner. All attempts to find my eBox have failed. They have not returned my emails telling them of my problem. Why doesn’t SanDisk just give us the answer in the first email? I have been fighting this for a couple days now. The very first time I clicked on it, I actually got a real page. But there was NO place on the page to log-in. Now that page will not come back up.

I hope someone from SanDisk will respond or fix the broken link to their eBox.

Take heart. Once I wrote them they fixed my link. I have no idea what they did. I did not receive any emails. I just found that all of a sudden it worked and has continued to work. Good Luck!

Thanks for the encouragement!

I am still having issues with my EBox. I called a technician on Friday and she was able to open it, however, she said there was nothing posted to it. I received two more emails from sandisk on Saturday, stating that there was information in my EBox, along with an RMA and UPS label to return my product. I could not open the link.  I tried again on a different computer this morning and was able to open the page one time, which showed a box and the word eBox. It is not a link, just a picture. I wrote down the URL which opened the page, because past experience has taught me that this page will only open one time per computer (this was the 4th computer I’ve opened the page with)…

So, upon going back to my computer with the URL, I received this message (what is going on with this?):

There is a problem with this website’s security certificate.

 

 

    The security certificate presented by this website was issued for a different website’s address.  
Security certificate problems may indicate an attempt to fool you or intercept any data you send to the server.

 

We recommend that you close this webpage and do not continue to this website.

 

Recommended iconClick here to close this webpage.

 

Not recommended iconContinue to this website (not recommended).

 

More information  More information

dont worry about that, just click continue to website. 

I followed advice from another thread on this forum about blank ebox pages, and they recommended clearing all cookies, history and temp internet files. I did this and was then able to get to the log-in page.

I did the same thing but was still unable to get in. However, once I sent an email to Sandisk, my problems were solved.

After logging out, I was unable to reach the page again–just got the Done message at the bottom.  I had to empty my temporary internet files once again. I do wonder why they make it so difficult to reach the eBox page…

I received my return authorizaton letter, but cannot find myu eBox for my shipping label. Please advise. Thank you: Me59to60@aol.com