Can no longer access my 4GByte USB Scandisk Cruzer Blade

My Dell PC (XP SP3 Operating system) still recognises my 4GByte USB Scandisk Cruzer Blade, but now prompts 'the disk in drive G is not formatted. Do you want to format now?

I suspect the drive is full as I have intended deleting a few files for some time - but not got round to it. The last time it functioned I copied a software file onto the drive for a colleague. He borrowed the blade, copied the file and returned it to me. 

Is there some way I can ‘safe format’ the drive without erasing the data on it or another method of recovering/restoring the blade.

Is there some way I can ‘safe format’ the drive without erasing the data on it or another method of recovering/restoring the blade.”

Not to my knowledge.  I suspect your friend didn’t Safely remove the device when done using it.

I recommend trying it another pc or two.  You could try running CHKDSK on it and see what it reports.

CHKDSk reports: The type of file system is RAW. CHKDSK is not available for RAW drives.

I’m working from home today. Will be in the office tomorrow and try some other machines.

Thanks - though I’m now thinking its terminal. When I right click - properties: it shows type = removable disk; file system = RAW; used space = 0; free space =0; capacity =0

Try different OS’s also.  Win 7, XP, Win 8.  Let us know what happens.

Tried Win 7 & XP - no joy. Colleague (system administrator) used some recovery software but couldn’t find anything.

Went through Scandisk Tech Support who supplied a link for LC recovery software company. Downloaded demo recovery software, but again failed to find any files. Spoke to their tech support who supplied another link for some more advanced software. Again no files found. Spoke with them and its now confirmed drive is clean and empty - somehow? 

Their Filerecover software checks Hexadecimal block data - all zeros.

Sorry to hear the bad news frnkbrwn

Since you have nothing to loose at this point, try doing a Quick format of the drive, not a Full format, then try the file recovery tools.  Either the ones from work or from this posting:

Good luck.

There are many reasons which could causes the usb drive shows not formatted message, but the data on the drive should be still there. you can follow this guide to recover them: recover data from not formatted memory card

Even it is about memory card, but works for usb drive also. I tried last time and it works.

hope this helps.

Hmmmm According to this webpage of the app you refer to:

Get Asoftech Data Recovery With Only 39.95 Now

the app is not free. So do you work for the company or are you just a regular SPAMmer?

Agree with Ed_P, you may have to do a quick format, and then recover your data, here’s some tool/tutorial that you can use

Thank you for agreeing with me Jen but your posting smells suspiciously like SPAM.  You’re 001-software app costs $39.95 and your Google shortened link to  SanDisk Data Recovery and Photo Recovery Software app costs $39.95 also.  And it’s not owned by SanDisk.