Can Fuze+ firmware be downgraded? Unhappy with current version (audiobook issues)

Since the 01.32.00A firmware went in, I haven’t been able to work my audiobooks the same way anymore. After going thru the forums, I see that it was decided by someone in SanDisk to make the books play in the Podcast folder now, and that the tags need to read ‘audiobook’ or ‘audiobooks’ (which I had long since done prior to getting this player.) I have some audiobooks that have over 300 tracks to them, and it was easier to work through them in the audiobook format with being to see a lot of the tracks versus the Podcast version where only three tracks are on the screeen at a time.

I have tried to downgrade the firmware manually, whether it’s 01.27 or 01.29 or 01.30 versions - the player refuses to downgrade. I’d rather go back to a version of the firmware that allows me to use the display and file format that works better for me rather than this Podcast bunching up.

Any suggestions folks on downgrading versions, or is it even possible? Some folks in the forums say they have done it, but I cannot.

Guess I’ll read up on future firmware versions before jumping into them.

Key issues with manual firmware installation versus using the Sansa Updater:

 

Be sure to select MSC mode, Settings > USB Mode > MSC for the installation.  Be sure to switch back to your preferred mode after the installation, if you use MTP.

Be sure to remove the microSD card with the Fuze+, so the firmware will load properly.  With a card mounted, the device will attempt to read the card.  We want the firmware installation to run unimpeded upon disconnect.

Be sure to download, then unzip the compressed firmware.sb file.  A compressed file will not be loaded upon disconnect.

Bob  :smileyvery-happy:

Thanks for the info, Bob. I have done all the steps listed per the forum and your instructions. I should have added from the prior attempts before asking for help that once the Fuze+ reboots after the update, it does not come up with asking for the country settings and such, but rather shows a ‘loading’ message and goes straight to the music screen. I’ve reset, formatted and restored the settings thru the Fuze+ settings, but no luck -  it stays stuck at version 01.32.00 A. Not sure where to go at this point, or to wait for another firmware update. Thanks!

Update: Tried applying 01.32.00A firmware update to player, and I did finally get a message after reboot that the firmware had applied successfully - first time I had seen that message come up. Attempted reverting again, but no-go.

I can’t downgrade off of 1.32.00A either.  That seems to be another feature of 1.32.00.  Unable to downgrade from it…

Nice…

I should have read better as well.  I’ve never had issues with not downgrading before, but now it seems you can’t. unless there is some super secret handshake I need to do.

Hey Bob!

I just updated my fuse+ & ended up w/same prob as every 1 else. My audio books r not compatable any more. :angry:

U have the solution, however, I’m not a computer whiz, so I need ur instructions translated n2 English. I don’t understand MSC & MTP mode.

Thx & have a nice day.

Bob:

I just went thru the user manual again & got what MTP & MSC r in the usb mode menu, so disregard my request 4 translation.

I’ll try 2 go back 2 ur post & follow the instructions u posted. If I have any prob w/it, I’ll repost w/prob.

Thx!

WOW! I’m more than just a little upset about what this updater did 2 my unit!!!. I even re-formatted my unit & re-downloaded my audio book in2 my unit & still unreadable file. The stupid updater is stil on my unit!!

I then went & put my sd card in & moved the audio files I already had on my puter. I then went 2 c if I could listen 2 them & when I hit the card menu, all I got was “slot radio”.  Then a music track w/ "unknown artist came up. 1st it played, but no sound. Then, I can’t get the touch pad 2 do anything.

Is there ANY way I can get this stupid updater off my unit?? It’s like Jason: I’M BAAAAKKKK!

B4 I installed the updater, I was working w/the manual & the touch pad & just getting used 2 the lock/unlock feature & where 2 put my thumbs 4 ff & rw.

Boy! If I hada known I was gonna b this screwed, I’d have NEVER put this prog on here.

U folks @ SanDisk r gonna get a boat load of these things back if u don’t do something about this right away!! Nice idea on paper, but in reality…sux!!I

I got this thing 4 Christmas. Best Buy will take returns until Jan 31. I obviously don’t have 3 months 2 wait 4 a revision 2 this prog. I guess I better busta move & get down there b4 I get stuck w/this piece of crap.

Donna

What do you mean about the updater being on your device.

The updater is loaded on a computer connected to your device and reads the device and allows you to upgrade the firmware by downloading the firmware and then transferring it to the device.

I don’t know what you mean by getting the updater “off your device”.