c140 Has Multiple Same-Name Albums

I often change the music on my c140. Recently, when I finished a transfer, I started it up and began navigating the Album menu. Here’s what I found.

Among my albums, the recently added one was listed several times over (same name), and only had a couple of songs in each one. It had split up the 14 songs into different albums.

I re-connected the c140 and the WMP10 Sync menu showed the one album (not split up), with all 14 songs on it. So, I removed the recently added album. I checked all the tags on each song and made sure the album name was exactly the same. I also double-checked the “track number” on each song.

After doing this, I transferred the album back to the c140. The same problem is there!

How do I get these songs to show up as on one album?

Could it have something do do with the c140 being nearly full when I add the album? (Is the new album being put onto the player in fragmented spaces? Does it need to be “de-fragged” before adding more?)

so it doesnt do it when the player is not nearly full? so if you format it and transfer an album that was previously fragmented, it no longer will be? (fragmented that is)

They say timing is everything…

I was going to go ahead and try removing all the songs, and re-adding them. But a new problem just occured.

Now, it’s stuck on the song that was playing when I last turned it off. The song does not play, but it isn’t paused, either. It’s frozen. All of the buttons are unresponsive, and the unit will only turn on (not off). I have to remove the battery to turn it off.

I tried hooking it up to my computer (which I’ve never had any problems doing), and the player will not go into MTP mode. The computer won’t recognize the device, either. I cannot add or delete any songs.

I found some threads about this happening on a similar model, and tried the “remove the battery, hold the power-button for 30 seconds, and replace the battery” trick. It didn’t work, so I sent a request to SanDisk.