Audio Files STILL Not Showing & Not In Order

Just bought a SanDisk Clip Sport because I’m tired of iPods and their complexity. I wanted just a simple MP3 player so I bought a SanDisk Clip Sport and it’s turning out that it’s becoming a complex pain in my rump.

I bought the 8GB model & a 32GB micro SDHC SanDisk memory card. I updated my firmware to 1.18 a few weeks ago. I have two music albums using the SanDisks internal memory placed in the “music” folder & I have “the word of promise” audio bible in my 32GB external memory placed in the “audiobook” folder. My two music albums work just fine and everything is displayed correctly. However my 32GB external memory with “the word of promise” audio bible is showing only about half the audio books of what is really there, not being in order & missing files in the books themselves. Such as book “Genesis” and files go 1, 2, 3, 7, 10,12,13,14, etc. To be more specific I have a folder for every book of the bible and then all chapters for that book within the folder. The ID3 tags are all correct & set accordingly.

At this point I have no idea what I’m doing wrong or what to do next. Any feedback or advice or answers would be greatly appreciated! The only other thing I can possibly think of is the firmware itself and that I’ll just have to wait until they release a more updated firmware version.

All in all I’m very disappointed with this product. While it holds great potential the fact that files are not being sorted correctly and then others completely missing is just horrible and I can’t believe, but yet I can, that they would release this product on the market with such problems. I just might have to look to buy a different product or go back to an ipod. At least this was only $50.00.


What is the format of the files?  Supposedly, alpha sorting was fixed for MP3 files, not so much for other formats.

1 Like

Everything is mp3 format. The total number of audio files is 1182-ish and I transferred them all at the same time.

I deleted everything and uploaded again thinking it was a glitch and same thing happened. I even tried putting the files in order of numbers first and then the book title after so it wouldn’t sort alphabetically but to how I wanted them to be and same problem.

Some files show and being in order while others are not & just missing.

Yeah, I can confirm what OP is saying. Same thing happening here - I have some mp3 audiobooks and podcasts on my device and none of it is displayed in the correct order despite correct ID3 tags and track numbers being in front of the filename, and (just to be safe I guess) in the title.

Can you confirm which version of firmware? eg. v1.18

1.18 here, yup.

Ok so here is what I have discovered today through trial and error. I decided to downgrade to firmware 1.17. Same problem so that didn’t help. What I did do was copy my audio books little at a time onto my external memory card. I was able to get the first 18 books onto the external memory. Every book has the individual chapters in them. A total of 478 files & 18 folders. They are all organized accordingly with no missing files.

However when I try to add anymore… they start to not show up or have missing files/folders both chapters and books. So it seems I am limited to what I can even add in my external memory card until I start having problems. The total amount of space used on my external memory card is 6.34GB. So… with this doesn’t that mean there is no need for an external memory card?

So frustrated… there is nothing more I can do… =(

1 Like

I’ve been using Sandisk for years and I’ve never had this problem before. In the past, it was always enough to ensure that the files were ordered alphabetically. Now, all of a sudden, Sandisk is not respecting the alphabetical order of the files. I looked at the creation date too, but that doesn’t explain the order. I cannot figure out what principle Sandisk is using to order the play. It’s not just random, because it chooses the same wrong order every time.