Audio drops from videos when playing USB 3.0 iXpand drive on iPhone 7 and on iPad Air 2

I have been having an issue that when trying to play videos that are on my SanDisk iXpand drive on my iPad Air 2 or my iPhone 7. I have been having the issue that for some videos the audio will drop 1/2 into the video. For some videos the audio drops after 2min of play time.  I purchased this iXpand drive just for storing videos, but the app constanly crashing and audio dropping is starting to be disappointing. This iXpand has the potential to be such a great product if the bugs can be fixed.

I originally was having another issue, but the recent software update solved it. When i was connected to blue tooth audio the SanDisk iXpand Drive app always crashes when connected to blue tooth audio. This issue was solved when i installed the new updated software iXpand drive 4.4.1 version.

I am using the SanDisk iXpand Drive app on both the iPad and the iPhone. I just loaded the updated (version 4.4.1 last night). I see that it solved the bluetooth issue, but the audio dropping when playing videos is literally driving me crazy. 

I would be so grateful if someone has a resolution for this issue.

does the audio cut out of you are using wired headphones? if not the fix for the bluetooth issue may not have fully solved the issue. can you test with wired headphones and let us know if you see the same audio cut out issue?

You are correct. I tested and still there is an issue with audio when playing videos files. I can’t try the wired headphones with the iPhone 7 because there is no headphone jack, but when i tried the headphone jack on the iPad the audio dropped after 2min of video play time. So you are exactly correct. The audio cuts out when using the headphone jack. 

sincd the audio does drop when playing videos with wired headphones is there a fix? You message stated… “if not, the…”  But since the answer is yes, is there a fix?

no sandisk

if you are seeing the same issue with audio when using wired headphones this is likely a different issue not related to the BT update. I have tested on iPad air 2 and iphone 7 and I am not seeing any similar issue when playing any video file types. Not sure what could be causing it in your environment. can you let us know what file types you are using? maybe it is format related?

These are typically either videos i have downloaded from website or from iTunesU. In either case they are always .mp4 video files. I am a graduate student in a science field and try to watch vidoes on science lectrues. If you have time to try the exact videos on your iphone or ipad then here are the videos i am having issues with…

at this URL, scroll down, and righ click any of the “view” items, below the Video colum, save as, and then try to play via the iXpand drive on the iphone or ipad.

video #9 in that list (9: Introduction to Metal Optics) is the one that has been giving me the most problems.

I can’t say thank you enough for all of the guidence and help thus far. I really appreicate it.

Ok so I downloaded video 9 and played it on my iphone 7. What I saw when the video first started playing was that it would actually pause about every 2 to 3 mins. The audio was not actually dropping but the video itself was pausing. Tapping the screen brought up the progress bar and you could see that the video was paused. Pressing play would resume the playback with the audio playing normally. this happened for about half of the video then it played the rest of the way without pausing.

I also tested 4 different MP4 files I have and did not see the issue at all. It seems the issue is mostly isolated to the source file. Looking at the video details it seems the file should be supported spec wise but it is encoded using Lavc51.9.0. the mp4 I have that are playing normally are encoded with x264. The issue with these files could be the encoding. 

As an immediate work around you could use a media converter app and convert the file so it would be re-encoded using a different library and that may solve the issue.  

I don’t think this is the same issue i was having. I could see the progress bar still moving and the video on the screen would be  changeing.  I just couldn’t hear it. So for me the audio was cutting out. I think we are having different issues. 

Maybe your suggestion of re-coding the vidoes would solve the issue. Any advice or suggestinos on how to accomplish this?

you would need to download a video converter application and use a computer to covert the video. I have used Any Video Converter in the past and it has worked well. it used to be free but I have not used it in quite a while. just run the video through the app and convert to MP4 and it should reencode the file which may solve your issue. 

I can’t say thank you enough. You have been a huge help. The videos are currenlty in .MP4 format. So i should convert from .MP4 into a .MP4 format and it will recode the videos and hopefully remedy the issue?  I downloaded Any Video Converter and its still free, so thanks for that suggestion.

Yes you should be able to convert using MP4 as the encoder in AVC is not likely the same encoder used for the files. If that does not work you can also try AVI or MKV but MP4 should be ok. 

Dr lucky

 You are a genius. I converted the files using any video converter and from now on I have not had that issue at all. Thank you so much.  

No problem at all. Glad it worked. 

TSPSC Degree College Lecturers Recruitment 2017 for Women’s- 546 Post’s/Vacancy MESCOM Jr Assistant Recruitment Results 2017- 984 Post’s & Cut Off Mark’s SCERT B.Ed Admission 2017 Application Form & Notification

Customer Online Information SupportCustomer Care Support- Toll Free Number’s, Email IdCustomer Care Toll Free Helpline Phone NumberResults 2017 | Job, Recruitment Vacancies 2017Customer Care & Toll Free Number -

Is there an update now?

i dont think there will be any update for this. the videos are using a very uncommon codec. The work around is to convert the videos. 

I am having the same issue, but can’t seem to understand the solution. I am playing a .mp4 file but the audio cuts out after about 5 seconds, if I scroll ahead and try to play the video again as “resuming” the video, the middle audio comes fine and then goes away again.

I am travelling and have no computer, this was going to be my way of watching movies. Is it possible to fix this just using my iPad?

.mp4 is a container. inside the container several different video and audio codecs can be used. this thread the video codec that was being used in the mp4 container was a non standard codec. this was causing the issue. the work around was to convert the file using a different video codec. if you can drop box us a link to one of the files you are having an issue with we can see if you have a similar issue.