Audio Book titles

Sansa Furze 4 G   I copy mp3 files - audiobooks 8 or ten chapers with bookname, track #.  It displays fine in Windows explorer but not on the Sansa.  Names are odd text inclueing Japanese characters. Please…what is wrong?  How can I fix? Thx, Hank

Your tags are in a format the Fuze doesn’t like. There are many ways to encode text, and your books are using one the Fuze can’t read. Windows is smarter–it can read more text encodings.

Download the free program mp3tag from

Install mp3tag.  When you install, let it add itself to context menus (an option while installing).

Open mp3tag and in Tools/Options/Tags/Mpeg make the Write option ID3v2.3 ISO-8859-1. This will fix the way the characters are displayed on the Fuze. ISO-8859-1 is Windows encoding. 

Right-click on the book folder. Highlight all the files and Save them in mp3tag. It will fix the format. Takes a few seconds. 

Try one book and see if it works, and if it does, do your whole library. Then run anything new through mp3tag before you add it.  Make sure you take the old versions off the Fuze and put the new versions on. 

If it still shows up strangely, you may need to refresh the database–the index of tags the Fuze makes. 

Go to Settings/System Settings/USB and make it MSC.  (Remember what setting you were using before.) 

Connect to the computer and look in the SANSA FUZE drive for MTABLE.SYS. If you don’t see it, go to your Windows Help file and search this phrase : Show hidden files and folders. (Because it’s a .sys file, for system, it may be hidden.) 

Find MTABLE.SYS, delete it, disconnect and the Fuze will build the database from scratch. 

Go back to whatever settings you were using in Windows for hidden files and folders and for the USB setting on the Fuze. 

Or, rather than changing the settings, he could put the power switch in the “hold” position, and press his choice of either the middle button, or the << button.