Admin Logout still not doing anything ?

I bought my media drive in 2017, flashed in the latest firmware, and the Admin Logout still doesn’t do anything ? After Log Out, and going to Login In screen, it has my password hidden, but filled in, so all I have to do is hit login. no password required.

Or, just Logout, go back to Home, and back to settings, and you are back to being Logged In


What is Admin Log Out for then ?

Feb 2017

It has the latest FW

Have you tried power cycling the Media drive? Log out of admin then close the app and power cycle the media drive. Once you have done that reconnect and go to settings in the app. Do you have to enter the password then? This is assuming you have set an admin password and are not using the default password. 

I have power cycled, and reformatted the drive for giggles.

It does not ever ask for the password. I tap Admin Logout on left, it immediately goes to a screen with a hidden password filled in (not label tho) with Log in in upper right. If I tap the Log in, it just goes back to the expanded Settings (WiFi, etc). There is a spinning beachbally thing. The upper right changes to Log out. Tapping that immediately (no spinning beachbally thing) to the Log in screen

I NEVER retype my password

If it says Admin Login (no WiFi, etc) in the left, and I click Home in upper left - then click Settings, I am giving access to all setting. Again, I NEVER type a password.

I don’t know if it isn’t actually logging out, or just filling in the password on its own for some reason and logging in. I do know I DON’T have to type it.

nobody else with v3.0.4 sees this ?

after many emails/phonecalls SanDisk acknowledged the problem, and said since Media Drive is EOL, they aren’t selling Media Drive anymore, and oh well, the problem won’t be fixed.