8gb SDHC recognized but not working..?

Okay, so, recently got an 8gb SDHC for my phone. When I first put it in, it recognized it, but trying to copy files to it just resulted in an error message. Looked around, people said to format it; I tried to format it in the phone, but just received another error message stating there was no card. After two tries of this it just refused to recognize it at all.

Tried putting it in my card reader (XP), it picked it up fine. After more looking, downloaded SD Formatter and ran that on it. Put it back in my phone, which now seems to recognize it (the memory card icon shows up, it didn’t before) but I can’t access the memory card settings in the phone options, and it doesn’t show up when trying to copy files to it.

I have tried turning the phone off, inserting the card, then turning it back on.

The card is a Class 4 8gb micro SD HC. Phone is a Samsung C5220.

Hope that’s all the info, and thanks for any help.

Unfortunately your phone only supports SD technology. Try to contact Samsung and ask if they have a firmware update for your phone to support SDHC technology


Crapbucket. That’d be right. I’ll do just that, but, well, not holding my breath.

Thanks much for the help.