8GB Compact Flash card allows to copy only part of the images


I have a Sandisk Ultra II 8GB compact flash card, which I have full of wedding photographs shot on my Canon 5D Mark II. Problem is I have difficulties to access the card on my PC, using an USB card reader (have tried several readers). Other cards show up fine.

The best I have been able to do was seeing all the files on the card, selecting all of them, and copying the first 6-7 files on my PC. After that the copy process stopped and I couldn’t continue it. I have spend now several ours, tried some recovery software like PhotoRescue, but there are two big problems:

  • very difficult to view the files on the card

  • copying all of them does not work

Any suggestions what to try next?


since some 6-7 phots are copying it means some part of your card is readale. some prts got bad sector or data error. try to copy as many phots as possible by selecting 5 or 10 in a group then fromat clar the card and possible go for formatting  to fix the carrd but be careful during this work, otherwise you may corrupt your card.