64gb Cruzer Switch: NFTS?

I recently purchased this 64gb stick.

When i tried to copy a 18gb file onto the stick i was getting the error that the file was to big.

I did some searching on the web and the problem was the stick was on Fat/fat32 format and can’t handle bigger files then 4gb.

So i formatted the stick to NFTS. It took several hours to format it, no quick format.

After the format was done, i still can’t copy anything to the stick.

When i check the properties, it says 0 bytes and nothing  about the NFTS.

When i try to format it again, it just won’t start.

I just can see the drive under E: and thats it.

Plz help!

Update: I just tried the HP USB Disk Storage Format Tool. I can select the stick, but when i press start to format it, it says there is no media in the specified device.

When i check devicemanager and can’t see the drive, but i can see it under computer (ctrl+E).

FAT32 can handle up to 2TB of volume. But if you’re using Windows XP, you’re only up to 32GB.

You can format your flash drive to exFAT.

It can allow you to copy a single 4GB file into your flash drive, too.

But NTFS is for hard drive.