1 videos left in my private vault after transferred

Yesterday I have transferred all my videos and photos into my ixpand drive, and then I put them into private access vault, it works fine I can view all of them and it asks me to delete them on my iphone to save space and I did. Then I tried to view some of the videos but it said it doesnt support the type, and asked my permission to open bluebooth (if I remember correctly), I denied it and it says couldn’t open the type of video, which was fine, I hop over to next image and it works perfect.
I could see all the files perfectly but after couple minutes all the videos in that file were gone and only one video left. I tried to open them on my computer but I have to install the private vault software, I created a password, logined, but it was a file type not regonized. I unplugged and tried again, this time I don’t know how to open the vault, I clicked on the only exe. and I think it installed again and said there was an exsisting vault if I want to use that, I answered yes, typed password, but it says incorrect password. And now I am stuck here with only 1 video left out of my 120 videos and images with no copies :frowning:
Please help me if you can :frowning:

Hi @wingexe1995,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:
https://support-en.wd.com/app/ask