Windows 10 installation error

Currently running 2 x 240gb Ultra II’s in a RAID 0. I’m trying to install the SSD Dashboard on Windows 10, but it keeps giving me an error:

“The Installation failed. Please try again later.”

Any tips on how to resolve this? I am currently using an administrator account. Below is the ending of the installdbservice.log if it anybody can decipher it:

Property(S): OriginalDatabase = C:\Program Files (x86)\SanDisk\SSD Dashboard\SanDiskSSDDashboardServiceSetup.msi
Property(S): UILevel = 2
Property(S): VSDFxConfigFile = C:\Users\ADMIN\AppData\Local\Temp\CFGFEE8.tmp
Property(S): ROOTDRIVE = D:\
Property(S): CostingComplete = 1
Property(S): OutOfDiskSpace = 0
Property(S): OutOfNoRbDiskSpace = 0
Property(S): PrimaryVolumeSpaceAvailable = 0
Property(S): PrimaryVolumeSpaceRequired = 0
Property(S): PrimaryVolumeSpaceRemaining = 0
Property(S): INSTALLLEVEL = 1
Property(S): SOURCEDIR = C:\Program Files (x86)\SanDisk\SSD Dashboard\
Property(S): SourcedirProduct = {EE9255E4-283A-4318-ABB6-A75BEE59ACA3}
Property(S): ProductToBeRegistered = 1
MSI (s) (8C:DC) [11:40:59:008]: Note: 1: 1708
MSI (s) (8C:DC) [11:40:59:008]: Product: SanDisk SSD Dashboard Service – Installation failed.

MSI (s) (8C:DC) [11:40:59:008]: Windows Installer installed the product. Product Name: SanDisk SSD Dashboard Service. Product Version: 1.0.0. Product Language: 1033. Manufacturer: SanDisk Corporation. Installation success or error status: 1603.

MSI (s) (8C:DC) [11:40:59:012]: Deferring clean up of packages/files, if any exist
MSI (s) (8C:DC) [11:40:59:012]: MainEngineThread is returning 1603
MSI (s) (8C:3C) [11:40:59:014]: RESTART MANAGER: Session closed.
MSI (s) (8C:3C) [11:40:59:014]: No System Restore sequence number for this installation.
=== Logging stopped: 10/25/2015  11:40:59 ===
MSI (s) (8C:3C) [11:40:59:024]: User policy value ‘DisableRollback’ is 0
MSI (s) (8C:3C) [11:40:59:024]: Machine policy value ‘DisableRollback’ is 0
MSI (s) (8C:3C) [11:40:59:024]: Incrementing counter to disable shutdown. Counter after increment: 0
MSI (s) (8C:3C) [11:40:59:024]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (8C:3C) [11:40:59:024]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (8C:3C) [11:40:59:024]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
MSI (s) (8C:3C) [11:40:59:024]: Destroying RemoteAPI object.
MSI (s) (8C:74) [11:40:59:025]: Custom Action Manager thread ending.
MSI © (D8:CC) [11:40:59:026]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
MSI © (D8:CC) [11:40:59:026]: MainEngineThread is returning 1603
=== Verbose logging stopped: 10/25/2015  11:40:59 ===


The only suspicious thing I can see in the log is the ROOTDRIVE = D:\ while SOURCEDIR= C:\Program Files…

I think there is some confusion to where the service needs to be installed. Probably due to your RAID 0 configuration.

Have you tried right clicking on the install setup file and going into properties and installing in windows 8 compatibility mode?

have you got any error before this ?


Impossible d’intaller sur windows10 Dashboard SanDisk SSD  le logitiel n’est pas accepte malheureusement. Toutefois cela fonctionnent bien sur windows seven . J’utilise  deux SSD  SanDisk- Plus 240GO ,j’en suis très content je me préocupe simplement pour savoir comment je vais faire pour mettre les mise a jours mes deux SSD PLUS 240.GO sont bien enregistré a la date du : 02/02/2016… et  je tourne sur un pc de bureau  sur la partition windows10 avec un SSD PLUS 240GO  comme lecteur principal a la place du sisque dur d’origine…Avec Aida extraime64 je controle la temperature et rien a redire 22 a 28 degré maximum avec un gain de performance de 95%



Can you give more details about the issue you are seeing. SSD Dasahboard is supposed to install and work without any problems on Windows 10.

Pouvez vous donner plus de details sur les problemes d’installation. Le Dashboard est suppose functioner sur Win 10…




Je viens de Résoudre Le Problème de mon écran grande résolution j’ai coché la casse accepteur la résolution Elevée et op! j’ai Installé le logitiel Dashboard sans problème et toute les Caractéristique du SSD Sont bien visible niveau correct en couleur verte Niveau bon de qualite et bonne, vitesse, température ok



I’ve reinstalled 1.4.1 and that installs fine, then run update and I get this error message


I’ve ran as admin; compatability mode; rebooted still fails :frowning:

Windows 10 Pro x64. I got the very same thing when trying to upgrade my original SSD Dashboard version. I installed SanDiskSSDDashboardService.exe before installing SanDiskSSDDashboardSetup.exe after failure of upgrade installation such as you have described. Setup then proceeded normally to completion You will find both installation files in the Program Files(x86)\Sandisk\SSD Dashboard folder after the failed installation. This upgrade setup faliure evidently has something to do with services. My original clean installation completed without a hitch. Suggests clean installation ONLY - upgrades will fail as you have shown. Go figure :wink:


Please uninstall your current version and make sure the SanDisk folder under “Program Files” or “Program Files (x86)” is clean.

When installing version 1.4.2, make sure the file “SanDiskSSDDashboardServiceSetup.msi” is present in the SSD Dashboard folder and that looking at the properties, the digital signature is from SanDisk and valid. Somehow that disgital signature was incorrect with the previous installer. Please report any issues regarding this, for example if you see an invalid digital signature. Thanks  

@georgealon  : your installation tips don’t work, first because the installer file isn’t a msi file, but it’s an exe file. Then, even if the SanDisk folder under “Program Files” or “Program Files (x86)” is clean, the installation failed. I don’t know what exactly what it occurs, and why the installation failed each time.

The only way that worked for me is the method of @paulyates :

@paulyates wrote:

So, I finally got mine working after numerous failed attempts. Here’s exactly what I did…


  • Download dashboard 1.4.1 from Major geeks and install.
  • Close dashboard (from system tray too),
  • Use control panel - Programs and Features to remove version 1.4.1.
  • Install 1.4.2

No other actions between these steps (IE No need to reboot etc).


I can only assume that the 1.4.2 upgrade does not remove everything it should when it deinstalls 1.4.1



Digital signature for my SanDisk SSD Dashboard Service Setup property shows Microsoft corporations. Is this why I can not update my pc to current 1.4.2?

Thanks for the suggestion - it worked!

The digital signature should be from SanDisk not Microsoft. You have the wrong installer. Please download the new 1.4.2 setup file (again).

I’m sorry that I didn’t explain myself well.  I ment say that a file of SanDiskSSDDashboardServiceSetup.msi property of digital signature is Microsoft.  NOT SanDisk.  Now what do I do?


Same problem here. 1.4.2 will not install over 1.4.1 (Windows 10).  Solution is to remove 1.4.1 from Control Panel before clean installing 1.4.2.


The digital signature should be from SanDisk not Microsoft and that’s why it fails to tinstall.

We found this issue and replaced the SanDiskSSDDashboardSetup.exe file on our cloud server. The new file is now with SanDisk disgital signature. Unfortunatly, sometimes Windows caches downloaded files and even after downloading the new updated file, it will launch the old one. Try to reset your cache and download the file from SanDisk support site again.

Sorry for the inconvinience.

I was notified update 1.4.2 by Sandisk SSD Dashboard at yesterday.

But failed update 1.4.1 to 1.4.2 

I can’t search the 1.4.1 anywhere.

Please someone upload legacy version.


Try to reset your cache and download the file from SanDisk support site again.

 It does not working. certifications is fine. (SanDisk Corporation - Symantec Time Stamping Services Signer - G4)

Works fine - Thanks