Video stops recording after 33 seconds

I just bought this because I was always running out of space on my iPhone 6plus. I tried to use it today to record my daughter’s event.  When I went back to view it, it had stopped after 33 seconds.  I tried taking another video and the length was 33 seconds again.  I decided to watch it the next time.  I started the video and after 33 seconds, the red record button changed but the counter kept going like it was recording.  When I viewed the video, it was indeed 33 seconds.  I conducted a couple more tests.  The video stopped recording at 33 seconds each time but the counter kept going.  Is anyone experiencing this or do I have a bad device?  This is a 128gb iXpand USB 3.0 for my iPhone.  

I’m tempted to just send this back.  

How much memory space to you have on your phone? I don’t believe you can record directly to the iXpand drive. You have to first record to the phone then transfer, or copy the video to the drive.

If you’re low on memory space on your phone, that might explain why it is stopping the recording prematurely.

What version of iPhone do you have? I have a iPhone 5s and iPhone 6 and video recording is working normally for me. Also how much free space do you have on your iPhone internal memory and what is the file size of the 33 second videos?

I have an iPhone 6plus running the latest 9.3.2 iOS.  I’m using the latest iXpand iOS app 3.1.4.  According to the app, if I access the video camera through the app, it records directly to the iXpand drive instead of the phone. 

Currently I have 312MB free on my phone, which is why I bought the iXpand drive.  My next phone will have more memory, but right now, I’m stuck with 16GB of memory.  The 33 seconds of video is only 66.8MB.  

Here’s what I have noticed.

I start the recording.  The red button shows that it is recording and the time ticker starts counting.  About 33 seconds into recording, the red button changes from its recording state, to a stopped state, but the time ticker continues to count.  If I press the red record button again, it begins recording again and the time ticker resets to zero.  If I wait until about 33 seconds, the red button changes but the time ticker continues.

This seems like a software issue.  Syncing from the phone is working fine.  I havne’t tried syncing the files to a computer.

Thoughts?

It seems like the video is possibly being recorded to the internal memory then moved to the iXpand drive. I am not sure if this is a Apple SDK limitation or an issue with the app. I was able to fill my internal phone memory and I saw a similar issue to the one you describe so it seems to be related to the amount of free internal storage the iOS device has. I opened a ticket with sandisk support to see what they have to say but if this is a limitation of the iOS SDK sandisk would not likely be able to solve it. 

1 Like

I spent about an hour with SanDisk support today.  They were able to replicate the problem and it is related to the amount of storage left on the phone.  When I started, I had about 340MB available and that equaled to about 33 seconds.  I deleted some apps so I had about 840MB and that allowed me to record up to 6 minutes but it did stop again.  

I’m a software developer so I can kind of guess what is happening.  As you surmised, it is most likely using phone storage (a cache?) during the recording and when it stops, immediately transfers the video to the drive. 

I wouldn’t have a problem with this behavior as long as I was aware that this was a limitation.  I purchased this because it said you could record directly to the iXpand drive.  At 128GB, that is a lot of video.  Unfortunately, with the current limitation, I am in the same position as I was before the drive.  I have to delete apps whenever I want to record lots of video.

One other abnormality I noticed.  When the app reaches the memory limit, it stops recording but the ticker continues so it appears that it is still recording.  This is obviously a bug and needs to be fixed.  You would think that there should be a way to flush the cache to the drive during recording so it doesn’t run out of phone storage space.  If I were writing the app, I would check to see what my free space on the phone and then make sure that I picked a cache amount that was less than the available space and then continue to flush the cache to the drive as I was recording.  This would require a couple of threads and I’m not sure if the OS is multithreaded or not.  I would hope it is, but there may be a limitation there also.

Support said they were going to escalate this issue and inform me of any solution they came up with.  I’m going to mark this as answered, but I will try to update this thread if they come up with a different solution.

sandisk support got back to me with basically the same info they provided you. They did confirm they would have a fix for the video time still going and will provide an appropriate message that the video has stopped recording in the next release. They also said they will investigate if there is anything that can be improved with the flushing of the cache. 

apparently this is limited to shooting video. the iOS SDK allows photos to be saved directly to the device. Videos however must be stored on the internal memory then moved to the drive. 

1 Like

Possible app developer solutions below:

This is very bad, many people doing good video need to record direct to external. It’s not going fit on icloud without a huge price.

I’m not a iPhone developer and don’t know what is down there, but this sounds like lazy programming.

First. Is it possible to link a camera app, especially one that wants to do this, to take its data and send it to the storage devices app as its recording?

Second: A camera app doesn’t actually need to use the Apple video processing system. If the camera app can get the frames, you can compress them and send them to a drive application itself.

Third: Sandisk could lead the industry and make a work around that offers a simple highest speed external drive service specification to all developers to use to by pass the problem for good. Drives, USB converters for ssd, and micro sd wrap around low profile readers for phone case use, all with charging pass through and extra port (for microphone adaptors etc) could ideally have such an app so apps can use all these devices. I know people who would like to record at over 500 Mega bytes per second if they could. So, such a system should aim at doing a maximum sustained filming of at least 100 Mbytes per second for professional purposes.

Fourth. A shared internal storage space where as a camera app writes a block of storage the storage app sends it to a drive. If it is a circular buffer virtual drive, then it requires few blocks of storage as it overwrites blocks already backed up. Similar to this, is get the camera app (maybe through the storage specification above, to do single frames, or blocks of storage, and surrender them each as completed recordings, which are saved as the next one frame (like photos) or on storage block, is recorded.

Fifth. To help achieve the above, look if it is possible to get the camera app installed under the storage app, giving it dominion to carry out storage tasks. On Android I have seen this done with virtual firewall software.

Android is a bit easier, but it’s internal storage system is amazingly slow and clunky. Such a storage app on Android could institute high speed drivers, and media paths (and high speed high quality codec plugins). Drives that could allow this would be very popular in filming, as on many models, its pretty bad, for any descent resolution mode, and 8 bit 4:2:0 on 10-12 bit 4:2:2 suitable sensors.

There would be other tricks one could try, but drives that support these things would be a desirable product.

Thank you.