Strange characters(not English) displayed

This is the second clip+ I’ve had this problem with.  The display is not in English.  It is a language, if even that, I don’t recognize which is displayed.  It has been this way since the first time I turned it on.  I’ve tried resetting by holding the power button for 15 seconds, but that doesn’t change anything.

At the home menu, go to the Settings menu (the equalizer icon) then scroll down to the fifth line. That’s the Language setting. The first language on the list is English.

OK, try the folllowing to reset to English:

– press the small home button and navigate to Settings, and select it (press the center button)

– click up once (to get to System Settings), and select it

– click down 3 times (to get to Language), and select it

– select the top option that appears (English).

Hopefully, that will do it for you.

edit:  gwk, I think you may have provided directions for the Clip, not the Clip+.

Message Edited by Miikerman on 12-28-2009 07:55 PM

Thanks for the instructions, it worked and dropped my stress level immensely.

Great to hear that your blood pressure is down!   :slight_smile: