Someone please help me out, no videos work...

So I got this for x-mas.  Was really looking forward to using it, but almost EVERY single video I tried on the thing would freeze and crash the player.

Let me be more specific.  Here are the parameters of one of the movies I tried tonight that froze like the rest of them.

Size: 695mb
608 x 256
Audio Bit rate: 142kbps
Audio Format: Lame mp3
Frame Rate: 23 frames per second
Data Rate: 92kbps
Video Sample size: 12 bit
Video Compression: Xvid

To the best of my knowledge all these parameters are within the given restraints of the hardware and supported.

Symptoms are the same in each video…  they play fine for 5-10 minutes… maybe 25-35 on some… then all of a sudden.  FREEZE…  and eventually the screen goes back to the blue menu logo(though you can not access anything or see anything) and the player completely crashes…  have to remove the usb drive and reboot.   I haven’t noticed any correlation between when it crashes from movie to movie, for example its not when the frame rate kicks up or this is a lot of stuff on screen.

I could understand if it was a codec problem, or some sort of file extension confusion in which the player simply wouldnt recognize or support a given video…  but every single video comes right up in the menu, and they all load and play, at least for a short period before inevitably crashing.

Anyways, here is the kicker… this is my second 4gb Sansa Take Tv…  I returned the first one hoping it was a faulty unit, but the second does the exact same thing as the first.  Purchased both brand new sealed from Amazon.

Anyone have any ideas or similar problems?   Thanks for any and all help.

So just a quick update.  The movie that I outlined above finally did play all the way through… 

I tried a few more test runs and it froze and crashed again(at different spots) 2/3 times after. 

Seems like 1/5 of the time I get lucky and it plays through flawlessly… 80% it freezes and crashes.  This is the same for all video, have tried over 15.(mostly divx/xvid movies or tv shows)

I cant possibly imagine I am the only one to encounter this.  Maybe just not that many people have actually purchased this thing yet. 

Normally I would just assume I got a bad piece of hardware, but like I said, this is my second unit and it does the same thing as the first. 

I was hoping Take TV would be more popular and people would create some custom firmware or something in the interim while sandisk is working on the official update. 

Anyways,  if anyone else is noticing this “freeze and crash” problem with their videos please post here and hopefully we can get to the bottom of what is going on.  Thanks.

My 4GB unit works perfectly except for an occasional audio/video sync issue. Nothing like the crashing that you’re experiencing, though. Weird.

I, too, was hoping that someone would have come up with a software hack for this by now. More options, codec support, etc.

Maybe soon…

thanks for the reply.

Wondering what videos you are watching on it?

Just wondering if you are watching the same stuff as I am…  I use it and it seems geared toward torrent files though I guess someone might watch DL.Tv and stuff but really this thing was made for torrented movies. 

The little teaser videos that come pre-installed worked flawlessly, though they arent of any comparable length to a feature film and all the movies I have started work well for at least 5-10 minutes.

From the participation on the message boards(admittedly not the best barometer), it doesnt look like the Take Tv is exactly flying off the shelves.

I imagine not a lot of people know what it is, which would explain  why its not flying off the shelves. They did announce it nicely at CES, so maybe that will all change.

Any videos with divx or xvid codecs in mp4 format should work fine, i use works perfectly for me.

Really weird, since I made this thread I haven’t ran into anymore skipping problems or anything.  Works great now for some unknown reason.  I didnt convert any of the files, used the same movies and everything has worked perfect.  Even FF and Pausing for length of time works fine.   Maybe in the windows sync process of deleting everything and putting it back on had something to do with it, thats all I can think of that I might have done to fix it.

I cant really explain it but I am just glad it is working and am crossing my fingers I wont have any more problems.

Hopefully it will be more popular so sansa wont abandon it and we cant get some custom firmwares from the community at some point, right now though I think it is just above the heads of most consumers and they will just continue to either watch movies on their computer or use Nero to burn them.