Sansa Clip+ stopped working (only a clicking noise can be heard)

Well, on october 11th i bought my sansa clip+ 4g and was pretty happy with it. Few days later the player froze, so i read online how to hard reset it and it worked fine until today:

I was listening to some music when the sound stopped and the player turned off by itself, out of nowhere. I thought at first it was the battery that was dead but when i tried, i could turn it back on again and was still some battery left. I promptly resume playing but the only thing that could be heard was a “clicking sound”. Since then i’ve done the following:

  • Hard reset
  • Downgraded Firmware
  • Upgraded Firmware
  • Changed headphones
  • Hard reset with no memory card
  • Formatted 
  • Checked volume

-----> The EQ works normally, as if it was playing.

None of those worked and the only sound that i can hear when i play my brand new Sansa Clip+ is the **bleep** clicking noise. 

I’'ve bought it over when i was in the US. Now i’m back in Brasil.

Any suggestions?

Thanks in advance!

Pretty much, I think you’ve done everything in the books. Next step here I think is to inquire about its warranty.