Sansa Clip 2GB problem.

I had this thing for about a year and a half and it was working perfectly. But all of a sudden it started turning off by itself in the middle of a song. After that, it would either never turn on and when it would, the letters would be upside down and had wierd letters (sometimes chinese and japanese looking). When I deleted a song, it would still show up on the player but when I tried to play it, it would lag and turn off again. I connected it to the computer and it turned on again. I got frustrated and formatted it once, restored all my music. The problems still showed up. This time even more. I then, tried to format it but it says “The device was unable to complete the format.” Now, when I try to put a song in, it “Cannot copy “song name”: The device has either stopped responding or has been disconnected”. It asked me to skip it. I use a USB cord to connect it to the computer.

Has any body ever had this problem before and if you did, how did you fix it or is there anything that I can do to try to fix it? 

Please help.

Thanks

I don’t know if it’ll help, but try a soft reset (on switch in uppermost position for 15-20 seconds) and reapplying the latest firmware?  Software glitches do occur.