SanDisk SSD U100 16GB unresponsive/broken

I have a Lenovo Ideapad Y500 with a SanDisk SSD U100 16GB. I’ve had this computer since Christmas 2012 and I was impressed by it’s speed and since it’s a rather powerful gaming laptop I was looking forward to at least a couple of years use before I had to replace parts. My SSD on the other hand was adamant in proving me wrong and I am now on the verge of destroying my laptop in a fit of equally awesome and terrifying rage several times a day.

To clarify: for at least a couple of months now my computer has been slow (when I got it, I timed the startup from off to desktop to 17 seconds, now it’s usually between 1 minute and 10), and new problems keep showing up and disappearing again (Unable to log in, black screen when accessing desktop, control panel uses 10 minutes to “load”, can’t access internet). Some problems, though, are more persistent, like the fact that I am unable to install some programs (mostly the ones who uses windows installer instead of a custom one) of which the most important is java. I am completely unable to install Java, at all. The installer doesn’t install, but there is no “not responding” message.

There is a plethora of other, smaller, problems that I couldn’t be bothered to put here, but the reason why I’m blaming all this on the SSD is that I keep getting messages saying that the disk is in danger, but if I try to open the SSD properties from Device Manager, the window freezes, everytime. I read somewhere that some people find their computer getting faster after a firmware update of the SSD, since I haven’t updated the firmware myself and I don’t know if it happens automatically I decided that I would try this through the promised sleek experience of the SanDisk SSD Toolkit. Which doesn’t work. When I open the Toolkit it instantly freezes and pisses itself, and it can’t be closed, even through task manager

Yesterday I formatted my whole computer and reinstalled windows, this might have gotten rid of some of the problems, I’m not sure yet, but I know that the computer is still unacceptably slow and the installation problem stays the same.

Thanks in advance.

That can be wear and tear. And you need to check the warranty with Lenovo. 

Wear and tear after just under a year seems like it shouldn’t happen, but if that is the case what SSD would you recommend that isn’t utter shait?

I think you might have problems with your primary hard disk, not the Sandisk U100 which is likely just being used as a cache, being only 16 GB big. And if it’s actually only working as a cache, then it should be easy enough to test whether it’s the cause of your problems, simply by temporarily removing it from your notebook. It should keep working fine, although ithe system might complain.

I’m not going to be able to test your theory for a week or so since i have a lot to do that i can’t do without my computer, but are you sure this can be the case? From the Warning messages i get I would put my money on the SSD being broken:

If you’re actually getting an error from the SSD and not a generic SMART failure for all drives, then it is probably due to that.

A temporary workaround would be disabling the SSD file caching your system is currently using. I’m not sure how this is performed on your PC, though, except physically removing the SSD from its slot.

So for a permanent sollution I would have to buy a new SSD, right?

I don’t think it can be fixed, but without seeing what the SMART errors actually are, one cannot be 100% sure.

Keep in mind, by the way, that your SSD is only acting as a cache. If you bought a new large capacity SSD (>128GB) it would likely be wasted for just that purpose. The best would be having your laptop vendor replace it with new one.

Luckily for you, since it’s acting as a cache (as far as I can tell) your laptop should still be usable even after you remove it, although it will likely be slower.

Replace what? The SSD or the computer.

Ideally, the SSD only.

Please note: I’m not a Sandisk employee.

Will any new SSD do, or is there some kind of restrictions I don’t know about? And since I don’t want to go through this process again, which SSD’s are the most reliable?

Not knowing the exact specifications of the SSD caching system used in your PC, I can’t really answer whether there is some kind of restriction or not. As for reliable SSDs I’m not sure I should be suggesting other manufacturers on this forum, but even looking only at SanDisk drives, Marvell-based ones such as the Ultra Plus (but not the “Ultra”) or the Extreme II/Extreme Pro (but not the “Extreme”. Please note the slight difference in naming) are known to be pretty reliable, with the former one being the budget model.

Recently made Sandisk SSDs are in general pretty reliable. Have a look at this page (in french):

http://www.hardware.fr/articles/920-7/ssd.html

I bought a new ssd (Plextor PX-64M5M, because screw Sandisk), installed it in my computer where the old one used to be, but my computer does not seem to use it at all. it does not show up in Devices and Drivers, nor does it show in the Intel Rapid Storage Technology. I tried looking up drivers or install instructions of any kind, but there is no explanation online i can find that doesn’t assume the reader has a Ph. D. in computer science. Why wont it just work?

I updated my Intel Rapid Storage Technology Drivers, and now the SSD shows up, and it has a checkmark on it showing that it works, but my computer is not any faster. There is no difference between now and when i didn’t have an SSD at all.

Do you have any option enabled under the “Accelerate” or “Performance” tab in the Rapid Storage control panel?

Something like this:

http://cdn.pcper.com/files/imagecache/article_max_width/review/2011-05-11/RST%20caching%20-%20acceleration-4.png

I don’t have an accelerate tab…

You need to have your storage controller set to RAID mode to enable SSD caching with the Intel Rapid Storage drivers, if your chipset supports it. However, even if it does, it isn’t very straightforward to both check it out and set it that way without potentially rendering your pc inoperable, something I don’t want to take responsibility for.

The ideal scenario would be being able to restore the functionality of the SSD caching system that was previously working with your SanDisk SSD. As for that, I have no idea however.

My computer does not seem to support RAID since i can’t turn it on in BIOS, only AHCI or IDE, don’t know the difference, nor have i tried to change since I don’t want to destroy my computer. So I guess i’m out of luck… thanks anyway.

I acctually found out what made the ssd cache work before. Since i have no RAID support there was a pre-installed program on my computer called ExpressCache wich made it possible for the HDD to write to the SSD. I followed this guide to try and fix the problem. As you see the guide refers to a windows 7 version of the program. At first i tried to use a windows 8 version, but that gave me the error “program is not licensed to run on this system” so I downloaded the Windows 7 (64 bit) version, and it seems to have worked since i now some feedback from the cmd command. CMD

However, I have yet to discover any significant increase in speed during boot time or acctual use of my computer, and i’m wondering whether or not this has acctually done anything.

Good job in managing to sort this out, at least in part. Assuming it’s all correctly working, it’s going to be a while before the caching software populates the SSD with data you routinely use, appreciably enhancing your computer’s responsivity. That’s the main difference between using a SSD as a cache and using it as a system drive, installing completely the operating system on it.

As you can see from the statistics you posted, only 16% of the total system reads (“cache read percent”) were fetched from the cache.

I’m not sure if this speeds up boot time as well. The caching system included in the Intel Rapid Storage drivers (on supported chipsets) doesn’t, and other ones from other software houses that I have tried don’t either.