Sandisk MicroSDXC 64gb Card stopped working after less than 12 hours of use!

Hey there! I bought a 64gb MicroSDXC card for my new smart phone… after 12 hours of use it just went corrupt! it wont read on any device and it won’t format either. It says that the capacity is only 30.6 mb and it is unformattable… I have tried everything i found on forums!

The problem is that i made a friend buy it for me from the United States ( So i think it will be very difficult for me to return it!

Any suggestions people ?! anyone knows what can be done to such problems ? 

Is your phone SDXC-compatible?

If you need to return it, just mail it back to your friend in the states and he can handle it from there. Amazon is very good (and fast) about returns.

Same thing only it lasted all of about 30min and now when i plug it into anything it gets so hot that I think it could burst into flames.

Then it’s defective. Return it and get another one.

I also purchased a 64 gb…after a month usage on my android phone…it went dumb…everytime i tried to delete files or copy new files or even make new files…its like it never happened. Tried different reader and does the same thing…create or delete file and when i eject and reinsert…its like it never happened…might this be defective as well? I will try to backup everything and format and see if that helps. :confused: