Sandisk Connect Flash Freezes


I am using my Sandisk drive with Ipad and it is loaded with a few hundred pdf files.

I can access the files OK usually, but after alittle use the drive freezes, and I cannot move to the next pdf.

I have tried resetting the drive, which again allows access for a few files then freezes again. I have updated the firmware to 3.4.1.

Any help please?

I have now also upgraded to iOS9, hoping that would fix it.

I opened maybe a dozen files, one after the other in one folder, then selcted another folder, and a file from it, and all I have is a grey sandisk screen.

I can go back to select another pdf, but still get the same grey screen.

any help, please. the pdfs are music files and I need to use this ipad for my performance.

i am getting desperate…

See the post below. It looks like there are issues with iOS 9. there is an update expected soon. Hopefully that will help with the issues you are seeing.  

Thank you for the reply.

I guess my main reaction to this is that I had the problem before I upgraded to iOS9.

I upgraded yesterday, and the problem has been around for at least a couple of weeks. Not sure when the last Sandisk upgrade was. Maybe it’s related.

Here’s hoping.

I have now discovered when the problem occurs, and a work around, I hope.

First I downloaded some of the pdfs from my flash drive to my ipad, so I had the files in two places.

Now when I open a pdf from the flash drive and expand it so it fills the screen (bottom rh corner button). It is from here the problem occurs. When looking to contract  with the same button to see the menu, it closes the pdf, opens the side menu, and then won’t let you select anything.

If you then go to the downloaded pdf , same thing, all ok until looking to contract screen size again, znd it freezes. The go back to flash drive and it works ok until same operation.

it seems flicking back and forth between the two allows usage, but not convenience.

This is driving me crazy.

When I open a pdf from my sandisk Connect on my ipad, it works fine.

When I expand it to see the whole pdf, by pressing the double arrow in the bottom RH corner, it still works fine.

That’s the end of it though.

When I select the double arrow to reduce it back I get a blank sandisk screen, and any further selection keeps the same blank screen.

Surely I am not the only person experiencing this? Does anyone have a solution?

Is there any sign of an update to correct this. I desperately need to see the whole screen, and change pdfs regularly.