ReadyCache via ESATA and Installer crashing at 0% install


I have an HP 6470b Probook that I am trying to install the 32gb Ready cache

I currently have the drive connected to the ESATA port on the laptop and windows see’s the drive without issue.

When I launch the latest Express Cache installer it gets me all the way to the starting of the install (0%) and the program just closes, no error no nothing. I have tried running as an administrator (same result), XP compatibility (same result)

Is this due to the ESATA Port?

I will have the 2nd harddrive adapter in this week, just wanted to test it before hand

IIRC this is only supported on internal sata and the SSD and HDD need to be on the same SATA controller of it will cause cache reset issues. 

I have installed the readycache drive in the 2nd hard drive upgrade slot in my laptop.

I am getting the same result.

When installing it starts at 0% and crashes the application

Is there a way to download the older version of the software to see if it will work on my system.

In device manager and properties the drives are on the same controller

I was able to get on with chat and found the issue.

I had to be logged in as the Administrator to get the readycache software to work.

It is loading now without issue

Hope this helps others