New Firmware for Ultra II 960GB drive --- Any info on what I just did????

I just received this email:

A new version of firmware is available for SanDisk Ultra II 960GB(SN:xxxxxxxxx) drive in your EILAP2-PC system. The new version is X41310RL.

I installed it, and everything worked fine… (Boot Drive, with 4 different partitions)  W7-64

Anybody want to tell me more on what I just did??? 

Release Notes ???

SSD Using AHCI and bios is Latest/Last A19

Something tells me that Release Notes on this new Firmware would be incredibly helpful… Dashboard gives you Release notes on New Dashboard versions, but not in the Firmware area…

Unfortunately, I couldn’t find any firmware release notes on the web site.

Anyway, I did the update. So far no problems. (Win7 64-bit OS)

Thanks for checking for me… Maybe  an employee will drop by and have pity on us!!

Thank you for contacting SanDisk® Global Customer Care. The new firmware update X41310RL for SSD Ultra II 960G includes minor bug fixes and feature enhancement. However, the release notes are not available at the moment.

Dear Jan,

I appreciate your continued response. As if now we do not have any information or update regarding the release notes for this firmware and we cannot promise that there will be release notes available for the drive.


For more information or further assistance, you can contact us at 1-866-726-3475 from 11am - 10pm EST (Monday - Friday) or reply to this email. We would be glad to assist you.

Best regards,

Daniel B.

SanDisk® Global Customer Care


I have 480GB Ultra II. It seems to fix the “SATA 6Gb goes to 3Gb” in reboot bug.

On my Laptop: Dell XPS 1702x, Firmware Update Worked, on 960GB Ultra II SSD.

On my Desktop: Supermicro, Firmware Update Failed with “Error 18” on 240GB Ultra II SSD.

Hi JanJ,

Please provide the following information for us to research on the firmware update error: 

  1. Is the SATA mode in BIOS set to legacy (IDE)/AHCI/RAID?
  2. What is the host – Intel/AMD?
  3. What is the driver? Intel/MSFT? Driver version?
  4. Is this a primary drive or a secondary drive?
  5. Drive model string?

what happened my post with the requested information?

it looks like it is in a different thread 

Thank You, I got the two threads confused! :)!

Thank you for providing the information. The firmware update was made mainly for manufacture process improvement and it is completely to stick with the firmware that it already has. We have reported this to our engineering team Again. In case if you are experiencing any issues while using the drive like errors or performance. You can let us know.

Thank you JanJ, 

We will forward your information to our engineering team, while they are investigating this issue you can still run the original firmware. 

If you are experiencing any other issue while using the drive please feel free to let us know. 

Hi JanJ,

I just talked to our engineering team and they said at this moment our update tool does not support IDE/Legacy mode, do you have access to a system that had AHCI ?

No… AHCI support from this controller on this computer (as mentioned before) only works on drives in a Raid Configuration…  And this is SE, so obviously…NO.

Aren’t you limiting yourself from thousand’s of user’s who want to upgrade their older Laptops with this approach?