MP3s disappear when I load them on to Sansa Fuze

I’ve got an album that I’m trying to load onto my Fuze. 

I drag the files and they appear in the Fuze. 

I disconnect and turn on the Fuze but the files don’t show up.

I reconnect and the MP3s disappeared from the folder they were moved into. 

Any help?


The same thing is occurring with any mp3 so it doesn’t appear to be the mp3s themselves…

I’m guessing the ID3 tags.  Search the forum for all kinds of information.

Just to verify, under folder navigation (Music->Folders), do you see your files? 

I’m unable to see them in Windows Explorer or in the device itself. 

I add them and disconnect

I reconnect to my computer and they’re gone.

It will show the folder they’re in but the folder will be empty.

I’ve had this for 6 months or so now and uploaded a few gigs of music without ever encountering anything like this.

@kmk_01kmk wrote:

I’m guessing the ID3 tags.  Search the forum for all kinds of information.


I agree. If the ID3 tags are missing, wacky with foreign characters, Comments field full of Lord-knows-what, or of a version other than ID3 v2.3 ISO-8859-1, then your Fuze can’t ‘see’ it. It files all these under “Unknown” Artist in the lists you see on your player.

If your firmware is up to date, Folder browsing is available and your missing music should be able to be found and/or played from here. But it’s also a good idea to fix your tags. :wink:

Tags are not the problem here. Windows Explorer can’t see them either.

Files loaded in one USB mode (MTP or MSC) can only be seen if your player is connected in the same mode as when the files were transferred. Have you tried switching the USB mode and looking again (in Explorer)? Don’t use the Auto Defect setting for the obvious play-on-words issue.

I wasn’t aware of the USB mode problem.  Good to know for the future but it didn’t get me up and running.

In other bizarre news, the Fuze is showing 3 songs from the album I tried to upload but the files don’t appear to be anywhere when I look for them in Windows Explorer.

I might just have to format the Fuze’s memory.  I’m sure there’s a forum for that…

Simply stunning…  

I formatted the Fuze and now SOME MP3s are going in with no problem and others are disappearing after upload…

Any more ideas?

It just magically decided to work now.  I’m going to accept that and move on with my life.

Thanks for the tips, everyone!  I truly appreciate them!  None of them solved my problem but they’re all good for future reference!

If this happens again, maybe you should try using other supported formats. Perhaps (since you are using WMP) you should try WMA (I know there is some way of turning the DRM protection off), or WAV. This way, you could see if your device hates MP3’s, or if it hates everything.