Malfunction or feature?

I bought my 8gb Sansa Clip from Amazon about 6 months ago but it seems to have recently developed a fault.  Before I send it back I wanted to ask anyone if they had experienced the following and if so if there was a fix I could implement myself.


1: The clip boots up slower than it used to, takes upto 1 minute to start playing

2:  Battery life seems degraded by about 70% - and yes I am holding the power button down for 8 seconds to make sure it shuts down rather than goes into sleep mode.

3:  I cant delete any songs from it, I have tried using the clip itself, which says it has deleted the song but then its back again, I tried deleting songs using windows and it looks like they have gone but then they are back again.  Then I tried the format option on the sansa and it says - format complete but the songs are still there.

4:  The clip (when its working) always starts on the same song regardless of where I stopped even if I change the play options, although to be fair I have only reset it by using play all several times.

The updater doesnt update so I assume that the firmware is current.  Oh and the only folder I am using is the music folder and I have used up about 50% of the 8gb drive.  The tags are mostly ID3 with a few WMV and even less with no tag data, but the same songs have been on there when it was functioning fine previously.

Thanks for looking

I’d get it replaced under warranty.

ok thanks.

You might want to try a couple of things first: (1) reapply the latest firmware manually (see the firmware upgrade sticky thread at the top of the forum)–it can become corrupt over time; and (2) if that doesn’t work and you don’t mind losing the content on the player, reformat the player from its System settings (which will, among other things, erase the content (but not the firmware) on the player–that sometimes can fix odd issues. Good luck!