mac no longer detects improperly ejected sandisk ultra USB, Windows machine still can

Ok I’ve been losing my mind trying to fix this for the past hour or two but I’m at a loss.

Got a new Sandisk Ultra Flair 3.0 128GB USB for my Mac, reformatted it soon after to what I believe it was exfat so I could move files to windows if I wanted. All was well and working fine until I accidentally unplugged the USB from my Mac while running a video file off of it. Now my Mac is no longer able to detect the USB, but my crappy old windows laptop still can. I tried formatting the USB to exFAT, and fat32 using my Windows machine, but my Mac still is unable to read it… I’ve since tried basically everything I could find on google with still 0 luck.

Here are some facts:

  • The USB doesn’t show up on Mac in system information or in disk utility, or when I put in the command I found to show the active drives in Terminal… (I’ve made sure that Finder isn’t hiding it)

  • On my Mac I’ve tried restarting / shutting off the machine, as well as resetting the VRAM and the SMC.

  • My Mac can still detect other USB storage devices when I plug those in.

  • the USB still works fine on my windows machine

It’s a MacBook Pro (Retina, 13-inch, Early 2015) running Mojave.

Any wizards out there with a solution or some sort of idea / suggestion? Any guidance would be much appreciated. Clearly the USB is still functional, I just have no idea how to get my Mac back to detecting it…

1 Like

SanDisk flash drives 64GB and larger are manufactured as exFAT so no need to reformat them for large files.

Backup your files and return the drive to SanDisk for a free replacement.