Is it worth it?

I seem to be having more problems with sansa fuze than I am enjoying it. My players screen went black after a minute of use and stayed black until a reset it but a minute later it was black again. After about a week of that it just went totally black changing to white and not starting. My computer never recognized it then. And it stopped being able to even charge. I got a replacement with much trouble due to the serial code and id number or whatever rubbing off the back of the player. When I got the 2nd one it lasted only 3 or 4 months and the same thing happened. This time however, it was already past my warrenty because sansa didn’t reset it upon my needing a new player and the number rubbed off. My father threw it away being furious at the same issue and figuring it better to get a new one from a “more reliable” company rather than fighting for months probably to get something done for a player that would break again after a few months.

Maybe you put on a file the Fuze can’t handle.  Maybe, if it wasn’t charging, the cord was worn out or the USB connection setting was wrong. You could remove a bad file, or replace the cord, or change the setting. But if the Fuze is thrown away that’s obviously not happening.

I suggest an anger management course for your father, and using Google, online forums, or telephone technical support to try to solve problems.

Try another brand. They all have their own quirks.

I put on only mp3s. Picture files came with them once and a while. I used multiple cords on multiple computers and nothing. I even tried changing the settings on my laptop and nothing. New driver- nothing. The thing is, it worked before. Then all of a sudden it stopped after a few months of use. I can’t remove a file because no computer would recognize it. I looked for solutions before (with my first one) and found nothing. The agent from sansa had no help so he relpaced it and in a matter of months the problem repeated itself. We just got mad because it happened twice and they didn’t reset my warrenty in case it happened again so there was nothing we could do he didn’t think. I used to have creative players and my friends have apple ipods and there has not been problems with those.

It is entirely possible you got two lemons. Or maybe not.

It sounds like you didn’t change the USB setting on your Fuze. In Settings/System Settings/USB Mode there is a USB setting choice. MSC or MTP. MTP gets messed up sometimes.

Mp3 files with giant comments or huge imbedded images can sometimes stop the Fuze. Depending on where you get them, people sometimes try to stuff all kinds of giant garbage into mp3s. It can be removed with mp3tag.

iPods mostly deal with files coming out of iTunes, which makes sure they are compatible with iPod.  But if you look at an iPod forum, you’ll see iPod problems too. They aren’t magic.

If you ripped all your albums in Windows Media Player and always used it as your music-library software, you would probably have a smooth time with the Fuze in MTP mode–well, except that WMP isn’t quite as together as iTunes. But to me the good thing about the Fuze is that you don’t need any program between you and the Fuze–you can just drag and drop music onto it (MSC mode).

The Fuze has to deal with a much more varied bunch of files than the iTunes-iPod connection. Mp3s are not standardized–there are many different formats of tags, all kinds of junk in the Comments field, imbedded images, etc. Sometimes it just chokes on them. 

A Sandisk tech on the telephone should have walked you through reconnecting the second Fuze (power off, hold switch down, hold <<, connect) and finding the incompatible file. If not, then it’s Sandisk’s fault to have lost your business.