Internal Memory Gone

Hi there, 

I’ve had the Sansa Clip+ 8GB for about 4 years and I’ve had a 16 GB microSD card to supplement it for about 3 years and up until today, I’ve never had an issue with either.

However, today I went to listen to one of my old favorite albums (on the original, internal memory) and discovered it was gone.  

Everything stored on the internal memory was gone.  I restarted the Sansa Clip+, ejected the microSD card (thinking perhaps for some reason it had suddenly begun to conflict with the internal memory), and when I got home to my computer I tried to access the files that way, but nothing worked.  Looking at it on the computer, the entire 8 GB is now free, and when the microSD card is out, the my entire Sansa Clip+ says it’s empty.

The microSD card and everything on it is fine, no missing files and everything plays fine.

Last night I noticed the battery was extremely low and left it to charge overnight on my computer but I didn’t have it sync or add any new files.  I haven’t added any new files or fiddled with anything (or dropped it, got it wet, etc.) in the past month and a half, and was able to access all of my music, both on the internal memory and the microSD, multiple times since then.   

As far as I can tell, just one day it decided to erase everything on the internal memory.

Has anyone ever had this problem?  And more importantly, is there any way I can access my files again (most of that 8GB was off of an old, long-gone computer and I have no way of re-loading it onto the player, short of re-purchasing at least a dozen albums)?

That’s very bizarre. I suppose you have tried changing USB modes–Settings/System Settings/USB Mode–to see if somehow the mode switched and the files became invisible to your computer.  Try MSC and try MTP.

But if the Sansa itself say the memory is empty, that’s not good.

Beyond that, you could try file-recovery software that finds deleted files if you are lucky.

I have had good luck with the free versions of Recuva

and with Stellar Phoenix

It might get corrupted which happens rarely. I just hope recuva will still work for you here. 

This happened to me as well. I tried to drag and drop some mp3s from my android tablet to the clip and the memory was just empty! I blamed it on the tablet. But then I noticed that there was a LOST folder with about the same size as my music. Being a dope, I deleted this and put music back on from a PC. Something like recuva might have restored the stuff. And now, I can only put about 2 gig on it. BTW its a 4 gig player. Anybody have any ideas?

You probably have Settings/System Settings/USB Mode/Auto Detect. Try switching it to a single mode: MTP or MSC.

A computer or tablet can only see files that were sent in one mode at a time–the other files  are invisible. I don’t know if your tablet has MTP mode, so it was probably using MSC. Your computer may have been using MTP.

First try connecting to a PC in MTP mode,  and then in MSC mode,  and see if you find another 2GB of files.

If you’re going to be using both computer and tablet, take USB Mode off Auto Detect and leave it on MSC. If there were files in there on MTP mode, you might want to take them out (also via MTP) and send them over again via MSC so you can see everything at once.