Files eventually stop copying to my SanDisk iXpand v2.0 USB 3.0 Flash Drive 64GB - Please help!


I have recently purchased a SanDisk iXpand v2.0 USB 3.0 Flash Drive 64GB and am trying to copy the below files from my iPhone 6 to the Flash Drive.

4231 files (4134 photos, 97 videos)

I see a red status bar moving which eventually stops and it still says Copying 4231 files.

The file copy never completes and after waiting and waiting I eventually have to stop the process due to an almost flat battery.

When I do stop the process I have only copied 2319 files (8.96GB).

The total number of files being copied do not exceed 64GB.

I have also downloaded the latest iXpand App version 4.7 and my iPhone has the latest iOS 11.3 installed.

Please help!



do you have icloud photo library turned on? If so the photos may not actually be stored on your phone and would have to be downloaded to copy to the iXpand. You can check settings or in the photos app if you see all photos instead of camera roll it means icloud photo library is turned on. 


i don’t have icloud photo library turned on and confirmed that already by reading other people posts.


does it seem to stop at a particular file? there could be an issue with a file that is causing the transfer to hang. 

Also are you using the camera backup or are you using copy files? I would suggest trying both methods and see if there is any difference. 

Hi and thanks for all your help as I’ve tried everything and on another iPhone with same issues.

I’ve now returmed the SanDisk and got a refund of my money.

Thanks again for helping.

this seems to be a common problem, and i still haven’t found a fix for this at ALL online.

this is very disappointing.

i get stuck and now it doesn’t even function at all and just shows the  “iXpand Drive is full operation could not be completed” screen. and the buttons freeze and i have to shut the entire app down and restart.

this seems to be a common problem, and i still haven’t found a fix for this at ALL online. GBWhatsApp

I had this this problem.
My Sandisk stopped copying from my IPad (even though it said the SanDisk still  had 400mb of space still left on it.)

I had 5193 photos and some videos on it.
So I transfered these photos from the SanDisk to another computer…
And deleted them from the SanDisk  to make space.

Now it works again perfectly :slight_smile:

So the answer for me was: My SanDisk was full - so I cleared off some space on it.

I will suggest that you use iTunes or iCloud for backup. It is not easy to move iPhone data to a flash drive.